a0b6faaab4
This commit converts gdb to the package infrastructure, and therefore moves it from toolchain/gdb to package/gdb. The target package is now visible in "Package selection for the target" => "Debugging, profiling and benchmark". The main option, "gdb", forcefully selects the "gdbserver" sub-option by default. Another sub-option, "full debugger" allows to install the complete gdb on the target. When this option is enabled, then "gdbserver" is no longer forcefully selected. This ensures that at least gdbserver or the full debugger gets built/installed, so that the package is not a no-op. The host debugger is still enabled through a configuration option in "Toolchain". It is now visible regardless of the toolchain type (it used to be hidden for External Toolchains). The configuration options relative to the host debugger are now in package/gdb/Config.in.host, similar to how we have package/binutils/Config.in.host. Since gdb is now a proper package, it is no longer allowed to 'select BR2_PTHREADS_DEBUG' to ensure thread debugging is available when needed. Instead, it now 'depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG'. This option, in turn, is selected by the different toolchain backends when appropriate. The 'BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED' option is removed, since we no longer need to know when it is allowed to 'select BR2_PTHREADS_DEBUG'. Also, the 'BR2_PTHREADS_DEBUG' option is moved to appear right below the thread implementation selection (in the case of the Buildroot toolchain backend). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
70 lines
3.4 KiB
Diff
70 lines
3.4 KiB
Diff
diff -rduNp gdb-6.6-100/Makefile.in gdb-6.6/Makefile.in
|
|
--- gdb-6.6-100/Makefile.in 2006-12-18 08:21:19.000000000 +0100
|
|
+++ gdb-6.6/Makefile.in 2007-05-14 10:54:29.000000000 +0200
|
|
@@ -331,7 +331,7 @@ COMPILER_NM_FOR_TARGET=@COMPILER_NM_FOR_
|
|
# CFLAGS will be just -g. We want to ensure that TARGET libraries
|
|
# (which we know are built with gcc) are built with optimizations so
|
|
# prepend -O2 when setting CFLAGS_FOR_TARGET.
|
|
-CFLAGS_FOR_TARGET = -O2 $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
|
|
+CFLAGS_FOR_TARGET = $(strip $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET))
|
|
SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
|
|
CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
|
|
LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
|
|
diff -rduNp gdb-6.6-100/Makefile.tpl gdb-6.6/Makefile.tpl
|
|
--- gdb-6.6-100/Makefile.tpl 2006-11-15 00:26:39.000000000 +0100
|
|
+++ gdb-6.6/Makefile.tpl 2007-05-14 10:54:29.000000000 +0200
|
|
@@ -334,7 +334,7 @@ COMPILER_NM_FOR_TARGET=@COMPILER_NM_FOR_
|
|
# CFLAGS will be just -g. We want to ensure that TARGET libraries
|
|
# (which we know are built with gcc) are built with optimizations so
|
|
# prepend -O2 when setting CFLAGS_FOR_TARGET.
|
|
-CFLAGS_FOR_TARGET = -O2 $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
|
|
+CFLAGS_FOR_TARGET = $(strip $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET))
|
|
SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
|
|
CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
|
|
LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
|
|
diff -rduNp gdb-6.6-100/gdb/configure gdb-6.6/gdb/configure
|
|
--- gdb-6.6-100/gdb/configure 2006-12-17 16:38:59.000000000 +0100
|
|
+++ gdb-6.6/gdb/configure 2007-05-14 10:55:41.000000000 +0200
|
|
@@ -272,7 +272,7 @@ PACKAGE_STRING=
|
|
PACKAGE_BUGREPORT=
|
|
|
|
ac_unique_file="main.c"
|
|
-ac_subdirs_all="$ac_subdirs_all doc testsuite"
|
|
+ac_subdirs_all="$ac_subdirs_all doc"
|
|
# Factoring default headers for most tests.
|
|
ac_includes_default="\
|
|
#include <stdio.h>
|
|
@@ -3055,7 +3055,7 @@ _ACEOF
|
|
|
|
|
|
|
|
-subdirs="$subdirs doc testsuite"
|
|
+subdirs="$subdirs doc"
|
|
|
|
|
|
# Provide defaults for some variables set by the per-host and per-target
|
|
diff -rduNp gdb-6.6-100/gdb/gdbserver/configure gdb-6.6/gdb/gdbserver/configure
|
|
--- gdb-6.6-100/gdb/gdbserver/configure 2006-11-22 01:10:19.000000000 +0100
|
|
+++ gdb-6.6/gdb/gdbserver/configure 2007-05-14 10:54:29.000000000 +0200
|
|
@@ -1239,7 +1239,7 @@ echo "$as_me: error: \`$ac_var' was not
|
|
ac_cache_corrupted=: ;;
|
|
,);;
|
|
*)
|
|
- if test "x$ac_old_val" != "x$ac_new_val"; then
|
|
+ if test "`echo $ac_old_val`" != "`echo $ac_new_val`"; then
|
|
{ echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5
|
|
echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;}
|
|
{ echo "$as_me:$LINENO: former value: $ac_old_val" >&5
|
|
diff -rduNp gdb-6.6-100/gdb/testsuite/configure gdb-6.6/gdb/testsuite/configure
|
|
--- gdb-6.6-100/gdb/testsuite/configure 2006-06-21 15:57:21.000000000 +0200
|
|
+++ gdb-6.6/gdb/testsuite/configure 2007-05-14 10:54:29.000000000 +0200
|
|
@@ -1248,7 +1248,7 @@ echo "$as_me: error: \`$ac_var' was not
|
|
ac_cache_corrupted=: ;;
|
|
,);;
|
|
*)
|
|
- if test "x$ac_old_val" != "x$ac_new_val"; then
|
|
+ if test "`echo $ac_old_val" != "`echo $ac_new_val"; then
|
|
{ echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5
|
|
echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;}
|
|
{ echo "$as_me:$LINENO: former value: $ac_old_val" >&5
|