34c2afeb75
Support for ARC CPUs was added in libffi after 3.0.13 vesion was cut and up until now no new release has been done. So to enale libffi on ARC we need this set of patches. These are corrsponding commits in libffi: * b082e15091961373c03d10ed0251f619ebb6ed76 - Add ARC support * 0f8690a84c874ec09a090c8c6adfb93c594acac6 - Rebuild for ARC additions * d918d47809c174d62283306b282749f8db93661f - arc: Fix build error The first patch was modified a bit (cut changelog part) to accomodate changes not related to ARC between 3.0.14 and changes in question. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Signed-off-by: Misca Jonker <mjonker@synopsys.com> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
44 lines
1.3 KiB
Diff
44 lines
1.3 KiB
Diff
From 5a1bbc8511464f073cb2e79d5aa9ea0395139541 Mon Sep 17 00:00:00 2001
|
|
From: Mischa Jonker <mjonker@synopsys.com>
|
|
Date: Mon, 8 Jul 2013 15:51:36 +0200
|
|
Subject: [PATCH 3/3] arc: Fix build error
|
|
|
|
One part of the patch for ARC support was missing in the upstreamed
|
|
version.
|
|
|
|
Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
|
|
---
|
|
Makefile.am | 2 +-
|
|
Makefile.in | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index b57b2a8..19ead77 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -172,7 +172,7 @@ if AARCH64
|
|
nodist_libffi_la_SOURCES += src/aarch64/sysv.S src/aarch64/ffi.c
|
|
endif
|
|
if ARC
|
|
-nodist_libffi_la_SOURCES += src/arc/sysv.S src/arc/ffi.c
|
|
+nodist_libffi_la_SOURCES += src/arc/arcompact.S src/arc/ffi.c
|
|
endif
|
|
if ARM
|
|
nodist_libffi_la_SOURCES += src/arm/sysv.S src/arm/ffi.c
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index be425d8..44c2551 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -852,7 +852,7 @@ src/arc/$(am__dirstamp):
|
|
src/arc/$(DEPDIR)/$(am__dirstamp):
|
|
@$(MKDIR_P) src/arc/$(DEPDIR)
|
|
@: > src/arc/$(DEPDIR)/$(am__dirstamp)
|
|
-src/arc/sysv.lo: src/arc/$(am__dirstamp) \
|
|
+src/arc/arcompact.lo: src/arc/$(am__dirstamp) \
|
|
src/arc/$(DEPDIR)/$(am__dirstamp)
|
|
src/arc/ffi.lo: src/arc/$(am__dirstamp) \
|
|
src/arc/$(DEPDIR)/$(am__dirstamp)
|
|
--
|
|
1.9.0
|
|
|