6afba01e5d
All patches are simply refreshed, except
002-properly-detect-if-python-build.patch which is removed because an
identical fix has been merged upstream:
e128ea78e5
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
22 lines
651 B
Diff
22 lines
651 B
Diff
Add an option to disable the ossaudiodev module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2420,6 +2420,12 @@
|
|
fi
|
|
AC_SUBST(MPDEC)
|
|
|
|
+AC_ARG_ENABLE(ossaudiodev,
|
|
+ AS_HELP_STRING([--disable-ossaudiodev], [disable OSSAUDIODEV]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ossaudiodev"
|
|
+ fi])
|
|
+
|
|
# Check for support for loadable sqlite extensions
|
|
AC_MSG_CHECKING(for --enable-loadable-sqlite-extensions)
|
|
AC_ARG_ENABLE(loadable-sqlite-extensions,
|