The ssh2 pkg-config file could contain the following lines when build
with a static version of mbedtls:
Libs: -L${libdir} -lssh2 /xxx/libmbedcrypto.a
Libs.private: /xxx/libmbedcrypto.a
This static mbedtls library must be used to correctly detect ssh2
support and this library must be copied in libcurl.pc otherwise
compilation of any application (such as upmpdcli) with libcurl will fail
when trying to find mbedtls functions included in libssh2.
So, replace pkg-config --libs-only-l by pkg-config --libs.
Fixes:
- http://autobuild.buildroot.net/results/43e24b22a77f616d6198c10435dcc23cc3b9088a
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
(cherry picked from commit 624603328a
)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
From b5fbc486e805805efb8400373ccec2a3dee1c81b Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Mon, 21 May 2018 12:07:00 +0200
|
|
Subject: [PATCH 1/1] Fix link with ssh2 built with a static mbedtls
|
|
|
|
The ssh2 pkg-config file could contain the following lines when build
|
|
with a static version of mbedtls:
|
|
Libs: -L${libdir} -lssh2 /xxx/libmbedcrypto.a
|
|
Libs.private: /xxx/libmbedcrypto.a
|
|
|
|
This static mbedtls library must be used to correctly detect ssh2
|
|
support and this library must be copied in libcurl.pc otherwise
|
|
compilation of any application (such as upmpdcli) with libcurl will fail
|
|
when trying to found mbedtls functions included in libssh2.
|
|
So, replace pkg-config --libs-only-l by pkg-config --libs.
|
|
|
|
Fixes:
|
|
- http://autobuild.buildroot.net/results/43e24b22a77f616d6198c10435dcc23cc3b9088a
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 5569a26b4..9e2606885 100755
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2766,7 +2766,7 @@ if test X"$OPT_LIBSSH2" != Xno; then
|
|
CURL_CHECK_PKGCONFIG(libssh2)
|
|
|
|
if test "$PKGCONFIG" != "no" ; then
|
|
- LIB_SSH2=`$PKGCONFIG --libs-only-l libssh2`
|
|
+ LIB_SSH2=`$PKGCONFIG --libs libssh2`
|
|
LD_SSH2=`$PKGCONFIG --libs-only-L libssh2`
|
|
CPP_SSH2=`$PKGCONFIG --cflags-only-I libssh2`
|
|
version=`$PKGCONFIG --modversion libssh2`
|
|
--
|
|
2.14.1
|
|
|