54ffa4bfd3
- Update patch - Update hash of license file (update in year, git.mk added, lintian warning fixed): -2a75afca6f
-429c259584
-bc71a14a4a
- json-c has been dropped since version 20.08.00 and1a663dd3b3
- Update indentation in hash file (two spaces) This bump will also fix the following build failure with bison 3.7.1 thanks tocfd5f58707
: libtool: compile: /home/peko/autobuild/instance-1/output-1/host/bin/aarch64-linux-gcc -DHAVE_CONFIG_H -I. -I../.. -Wall -Wstrict-prototypes -fno-strict-aliasing -D_LINUX -DACPI_ASL_COMPILER -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Os -I../acpica/source/include -I../acpica/source/compiler -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Os -c aslcompiler.c -fPIC -DPIC -o .libs/libfwtsiasl_la-aslcompiler.o aslcompiler.tab.c:297:10: fatal error: aslcompiler.tab.h: No such file or directory Fixes: - http://autobuild.buildroot.org/results/3eeb20a24595ab1b790bd770ba745676225ef8b9 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Reviewed-by: Erico Nunes <nunes.erico@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
75 lines
2.5 KiB
Diff
75 lines
2.5 KiB
Diff
From 4c202c0fd7e5bd3264c720d715f05573047d9cf5 Mon Sep 17 00:00:00 2001
|
|
From: Erico Nunes <nunes.erico@gmail.com>
|
|
Date: Fri, 12 Aug 2016 23:11:56 +0200
|
|
Subject: [PATCH] fwts: do not use -Werror
|
|
|
|
Warnings come and go with various compiler versions, so using -Werror is
|
|
prone to cause build failures with various compiler versions, especially
|
|
newer versions that introduce new warnings.
|
|
|
|
Remove use of -Werror.
|
|
|
|
Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
|
|
[Fabrice: updated for 20.08.00]
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
src/Makefile.am | 2 +-
|
|
src/lib/src/Makefile.am | 2 +-
|
|
src/utilities/Makefile.am | 2 +-
|
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 0109d644..3ca599e1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1,5 +1,5 @@
|
|
AC_INIT([fwts],[0.1],[fwts-devel@lists.ubuntu.com])
|
|
- AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
|
|
+ AM_INIT_AUTOMAKE([-Wall foreign subdir-objects])
|
|
m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
|
|
AC_CANONICAL_HOST
|
|
AC_CONFIG_MACRO_DIR([m4])
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index 52c637dd..d9d73f1c 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -14,7 +14,7 @@ AM_CPPFLAGS = \
|
|
`pkg-config --silence-errors --cflags json` \
|
|
`pkg-config --silence-errors --cflags json-c` \
|
|
-pthread `pkg-config --cflags glib-2.0 gio-2.0` \
|
|
- -Wall -Werror -Wextra \
|
|
+ -Wall -Wextra \
|
|
-Wno-address-of-packed-member \
|
|
-Wfloat-equal -Wmissing-declarations \
|
|
-Wno-long-long -Wredundant-decls -Wshadow \
|
|
diff --git a/src/lib/src/Makefile.am b/src/lib/src/Makefile.am
|
|
index 54de7f44..e129ed16 100644
|
|
--- a/src/lib/src/Makefile.am
|
|
+++ b/src/lib/src/Makefile.am
|
|
@@ -24,7 +24,7 @@ AM_CPPFLAGS = \
|
|
`pkg-config --silence-errors --cflags json-c` \
|
|
`pkg-config --cflags glib-2.0 gio-2.0` \
|
|
-DDATAROOTDIR=\"$(datarootdir)\" \
|
|
- -Wall -Werror -Wextra \
|
|
+ -Wall -Wextra \
|
|
-Wno-address-of-packed-member
|
|
|
|
pkglib_LTLIBRARIES = libfwts.la
|
|
diff --git a/src/utilities/Makefile.am b/src/utilities/Makefile.am
|
|
index aa37de55..4d5297cc 100644
|
|
--- a/src/utilities/Makefile.am
|
|
+++ b/src/utilities/Makefile.am
|
|
@@ -16,7 +16,7 @@
|
|
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
|
#
|
|
|
|
-AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
|
|
+AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \
|
|
`pkg-config --silence-errors --cflags json` \
|
|
`pkg-config --silence-errors --cflags json-c`
|
|
|
|
--
|
|
2.17.1
|
|
|