70ad172e6e
Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
49 lines
1.6 KiB
Diff
49 lines
1.6 KiB
Diff
From dbfea83a7436cbac34cc883ab2b7befacaf02c40 Mon Sep 17 00:00:00 2001
|
|
From: Danomi Manchego <danomimanchego123@gmail.com>
|
|
Date: Tue, 23 Jun 2015 13:54:42 -0400
|
|
Subject: libpng: don't append prefix to symbol names in version script
|
|
|
|
Even if Blackfin GNU toolchain add prefix '_' to all symbols,
|
|
symbol prefix is not accepted in the link flag --version-script.
|
|
Don't append prefix in the symbols in the version script file.
|
|
|
|
Original patch by: Sonic Zhang <sonic.zhang@analog.com>
|
|
|
|
Rebase to apply cleanly.
|
|
|
|
Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
|
|
---
|
|
Makefile.am | 2 +-
|
|
Makefile.in | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index dcc5439..e543c81 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -231,7 +231,7 @@ contrib/tools/pngfix.o: pnglibconf.h
|
|
# interfering with the symbol file format.
|
|
SYMBOL_CFLAGS = -DPNGLIB_LIBNAME='PNG@PNGLIB_MAJOR@@PNGLIB_MINOR@_0'\
|
|
-DPNGLIB_VERSION='@PNGLIB_VERSION@'\
|
|
- -DSYMBOL_PREFIX='$(SYMBOL_PREFIX)'\
|
|
+ -DSYMBOL_PREFIX=''\
|
|
-DPNG_NO_USE_READ_MACROS -DPNG_BUILDING_SYMBOL_TABLE
|
|
|
|
if DO_PNG_PREFIX
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 975f931..a3e0552 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -747,7 +747,7 @@ SUFFIXES = .chk .out
|
|
# interfering with the symbol file format.
|
|
SYMBOL_CFLAGS = -DPNGLIB_LIBNAME='PNG@PNGLIB_MAJOR@@PNGLIB_MINOR@_0' \
|
|
-DPNGLIB_VERSION='@PNGLIB_VERSION@' \
|
|
- -DSYMBOL_PREFIX='$(SYMBOL_PREFIX)' -DPNG_NO_USE_READ_MACROS \
|
|
+ -DSYMBOL_PREFIX='' -DPNG_NO_USE_READ_MACROS \
|
|
-DPNG_BUILDING_SYMBOL_TABLE $(am__append_5)
|
|
|
|
# EXT_LIST is a list of the possibly library directory extensions, this exists
|
|
--
|
|
1.7.9.5
|
|
|