eb52ebc8bb
Patch for the libgcrypt-config path correction was accepted by the mainline for rsyslog. Updating the buildroot patch until a new version with the fix is released. Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
49 lines
1.6 KiB
Diff
49 lines
1.6 KiB
Diff
From 86d19e4e63c3fa5b9690991f3e29ffab93990acd Mon Sep 17 00:00:00 2001
|
|
From: Clayton Shotwell <clshotwe@rockwellcollins.com>
|
|
Date: Wed, 19 Mar 2014 08:28:55 -0500
|
|
Subject: [PATCH] configure: Allow overriding of libgcrypt-config
|
|
|
|
Allow the overriding of the libgcrypt-config path if it is not at
|
|
a standard location.
|
|
|
|
Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com>
|
|
---
|
|
configure.ac | 14 +++++---------
|
|
1 file changed, 5 insertions(+), 9 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 314c16e..bf017d2 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -797,22 +797,18 @@ AC_ARG_ENABLE(libgcrypt,
|
|
[enable_libgcrypt=yes]
|
|
)
|
|
if test "x$enable_libgcrypt" = "xyes"; then
|
|
- AC_CHECK_PROG(
|
|
- [HAVE_LIBGCRYPT_CONFIG],
|
|
- [libgcrypt-config],
|
|
- [yes],,,
|
|
- )
|
|
- if test "x${HAVE_LIBGCRYPT_CONFIG}" != "xyes"; then
|
|
+ AC_PATH_PROG([LIBGCRYPT_CONFIG],[libgcrypt-config],[no])
|
|
+ if test "x${LIBGCRYPT_CONFIG}" = "xno"; then
|
|
AC_MSG_FAILURE([libgcrypt-config not found in PATH])
|
|
fi
|
|
AC_CHECK_LIB(
|
|
[gcrypt],
|
|
[gcry_cipher_open],
|
|
- [LIBGCRYPT_CFLAGS="`libgcrypt-config --cflags`"
|
|
- LIBGCRYPT_LIBS="`libgcrypt-config --libs`"
|
|
+ [LIBGCRYPT_CFLAGS="`${LIBGCRYPT_CONFIG} --cflags`"
|
|
+ LIBGCRYPT_LIBS="`${LIBGCRYPT_CONFIG} --libs`"
|
|
],
|
|
[AC_MSG_FAILURE([libgcrypt is missing])],
|
|
- [`libgcrypt-config --libs --cflags`]
|
|
+ [`${LIBGCRYPT_CONFIG} --libs --cflags`]
|
|
)
|
|
AC_DEFINE([ENABLE_LIBGCRYPT], [1], [Indicator that LIBGCRYPT is present])
|
|
fi
|
|
--
|
|
1.7.9.5
|
|
|