0d327c267a
This commit bumps the Python3 package to use Python 3.4.0rc1. About the patches: * The patches below 100 are significantly changed, because like for Python 2.x, a good number of improvements have been made in the upstream Python for cross-compilation. Therefore, almost all of these patches have been modified. * All the patches above 100 are simply updated for Python 3.4.0, with a small refactoring for the handling of test modules. The details of the python3.mk changes are: * --without-ensurepip to tell Python to not use PIP at build time. * Many environment variables are no longer passed, they were specific to our cross-compilation patches * The fixup of the LIBDIR in the Python Makefile is no longer needed since Python has switched to _sysconfigdata.py for distutils configuration instead of parsing the Makefile. * A new post patch hooks touches the two files generated by pgen to make sure they are newer than the pgen sources, which ensures pgen is not built/executed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
83 lines
2.5 KiB
Diff
83 lines
2.5 KiB
Diff
Add an option to disable IDLE
|
|
|
|
IDLE is an IDE embedded into python, written using Tk, so it doesn't make
|
|
much sense to have it into our build.
|
|
|
|
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
|
|
|
|
---
|
|
Makefile.pre.in | 8 +++++++-
|
|
configure.ac | 6 ++++++
|
|
setup.py | 4 +++-
|
|
3 files changed, 16 insertions(+), 2 deletions(-)
|
|
|
|
Index: b/Makefile.pre.in
|
|
===================================================================
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1085,7 +1085,9 @@
|
|
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
|
|
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python3.pc)
|
|
-rm -f $(DESTDIR)$(BINDIR)/idle3
|
|
+ifeq (@IDLE@,yes)
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s idle$(VERSION) idle3)
|
|
+endif
|
|
-rm -f $(DESTDIR)$(BINDIR)/pydoc3
|
|
ifeq (@PYDOC@,yes)
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s pydoc$(VERSION) pydoc3)
|
|
@@ -1133,7 +1135,6 @@
|
|
html json http dbm xmlrpc \
|
|
logging csv wsgiref urllib \
|
|
ctypes ctypes/macholib \
|
|
- idlelib idlelib/Icons \
|
|
distutils distutils/command \
|
|
importlib \
|
|
turtledemo \
|
|
@@ -1209,6 +1210,10 @@
|
|
LIBSUBDIRS += $(XMLLIBSUBDIRS)
|
|
endif
|
|
|
|
+ifeq (@IDLE@,yes)
|
|
+LIBSUBDIRS += idlelib idlelib/Icons
|
|
+endif
|
|
+
|
|
ifeq (@TEST_MODULES@,yes)
|
|
LIBSUBDIRS += $(TESTSUBDIRS)
|
|
endif
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2737,6 +2737,12 @@
|
|
AS_HELP_STRING([--disable-lib2to3], [disable lib2to3]),
|
|
[ LIB2TO3="${enableval}" ], [ LIB2TO3=yes ])
|
|
|
|
+AC_SUBST(IDLE)
|
|
+
|
|
+AC_ARG_ENABLE(idle3,
|
|
+ AS_HELP_STRING([--disable-idle3], [disable idle3 IDE]),
|
|
+ [ IDLE="${enableval}" ], [ IDLE=yes ])
|
|
+
|
|
# Check for enable-ipv6
|
|
AH_TEMPLATE(ENABLE_IPV6, [Define if --enable-ipv6 is specified])
|
|
AC_MSG_CHECKING([if --enable-ipv6 is specified])
|
|
Index: b/setup.py
|
|
===================================================================
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -2183,11 +2183,13 @@
|
|
import warnings
|
|
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
|
|
|
- scripts = ['Tools/scripts/idle3', 'Lib/smtpd.py']
|
|
+ scripts = ['Lib/smtpd.py']
|
|
if not '--disable-pydoc' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
scripts += [ 'Tools/scripts/pydoc3' ]
|
|
if not '--disable-lib2to3' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
scripts += [ 'Tools/scripts/2to3' ]
|
|
+ if not '--disable-idle3' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
+ scripts += [ 'Tools/scripts/idle3' ]
|
|
|
|
setup(# PyPI Metadata (PEP 301)
|
|
name = "Python",
|