0d327c267a
This commit bumps the Python3 package to use Python 3.4.0rc1. About the patches: * The patches below 100 are significantly changed, because like for Python 2.x, a good number of improvements have been made in the upstream Python for cross-compilation. Therefore, almost all of these patches have been modified. * All the patches above 100 are simply updated for Python 3.4.0, with a small refactoring for the handling of test modules. The details of the python3.mk changes are: * --without-ensurepip to tell Python to not use PIP at build time. * Many environment variables are no longer passed, they were specific to our cross-compilation patches * The fixup of the LIBDIR in the Python Makefile is no longer needed since Python has switched to _sysconfigdata.py for distutils configuration instead of parsing the Makefile. * A new post patch hooks touches the two files generated by pgen to make sure they are newer than the pgen sources, which ensures pgen is not built/executed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
58 lines
2.6 KiB
Diff
58 lines
2.6 KiB
Diff
Adjust library/header paths for cross-compilation
|
|
|
|
When cross-compiling third-party extensions, the get_python_inc() or
|
|
get_python_lib() can be called, to return the path to headers or
|
|
libraries. However, they use the sys.prefix of the host Python, which
|
|
returns incorrect paths when cross-compiling (paths pointing to host
|
|
headers and libraries).
|
|
|
|
In order to fix this, we introduce the _python_sysroot, _python_prefix
|
|
and _python_exec_prefix variables, that allow to override these
|
|
values, and get correct header/library paths when cross-compiling
|
|
third-party Python modules.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/Lib/distutils/sysconfig.py
|
|
===================================================================
|
|
--- a/Lib/distutils/sysconfig.py
|
|
+++ b/Lib/distutils/sysconfig.py
|
|
@@ -16,10 +16,17 @@
|
|
from .errors import DistutilsPlatformError
|
|
|
|
# These are needed in a couple of spots, so just compute them once.
|
|
-PREFIX = os.path.normpath(sys.prefix)
|
|
-EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
|
|
-BASE_PREFIX = os.path.normpath(sys.base_prefix)
|
|
-BASE_EXEC_PREFIX = os.path.normpath(sys.base_exec_prefix)
|
|
+if "_python_sysroot" in os.environ:
|
|
+ _sysroot=os.environ.get('_python_sysroot')
|
|
+ PREFIX = os.path.normpath(_sysroot + os.environ.get('_python_prefix'))
|
|
+ EXEC_PREFIX = os.path.normpath(_sysroot + os.environ.get('_python_exec_prefix'))
|
|
+ BASE_PREFIX = PREFIX
|
|
+ BASE_EXEC_PREFIX = EXEC_PREFIX
|
|
+else:
|
|
+ PREFIX = os.path.normpath(sys.prefix)
|
|
+ EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
|
|
+ BASE_PREFIX = os.path.normpath(sys.base_prefix)
|
|
+ BASE_EXEC_PREFIX = os.path.normpath(sys.base_exec_prefix)
|
|
|
|
# Path to the base directory of the project. On Windows the binary may
|
|
# live in project/PCBuild9. If we're dealing with an x64 Windows build,
|
|
Index: b/Lib/distutils/command/build_ext.py
|
|
===================================================================
|
|
--- a/Lib/distutils/command/build_ext.py
|
|
+++ b/Lib/distutils/command/build_ext.py
|
|
@@ -248,7 +248,10 @@
|
|
if (sysconfig.get_config_var('Py_ENABLE_SHARED')):
|
|
if not sysconfig.python_build:
|
|
# building third party extensions
|
|
- self.library_dirs.append(sysconfig.get_config_var('LIBDIR'))
|
|
+ libdir = sysconfig.get_config_var('LIBDIR')
|
|
+ if "_python_sysroot" in os.environ:
|
|
+ libdir = os.environ.get("_python_sysroot") + libdir
|
|
+ self.library_dirs.append(libdir)
|
|
else:
|
|
# building python standard extensions
|
|
self.library_dirs.append('.')
|