0d327c267a
This commit bumps the Python3 package to use Python 3.4.0rc1. About the patches: * The patches below 100 are significantly changed, because like for Python 2.x, a good number of improvements have been made in the upstream Python for cross-compilation. Therefore, almost all of these patches have been modified. * All the patches above 100 are simply updated for Python 3.4.0, with a small refactoring for the handling of test modules. The details of the python3.mk changes are: * --without-ensurepip to tell Python to not use PIP at build time. * Many environment variables are no longer passed, they were specific to our cross-compilation patches * The fixup of the LIBDIR in the Python Makefile is no longer needed since Python has switched to _sysconfigdata.py for distutils configuration instead of parsing the Makefile. * A new post patch hooks touches the two files generated by pgen to make sure they are newer than the pgen sources, which ensures pgen is not built/executed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
24 lines
1.1 KiB
Diff
24 lines
1.1 KiB
Diff
distutils: fix build_ext check to find whether we're building Python or not
|
|
|
|
The build_ext logic uses
|
|
sys.executable.startswith(os.path.join(sys.exec_prefix, "bin")) to
|
|
determine whether we're building a third-party Python extension, or a
|
|
built-in Python extension. However, this check is wrong in
|
|
cross-compilation mode, and instead, the sysconfig.python_build
|
|
variable should be used.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Index: b/Lib/distutils/command/build_ext.py
|
|
===================================================================
|
|
--- a/Lib/distutils/command/build_ext.py
|
|
+++ b/Lib/distutils/command/build_ext.py
|
|
@@ -246,7 +246,7 @@
|
|
# Python's library directory must be appended to library_dirs
|
|
# See Issues: #1600860, #4366
|
|
if (sysconfig.get_config_var('Py_ENABLE_SHARED')):
|
|
- if sys.executable.startswith(os.path.join(sys.exec_prefix, "bin")):
|
|
+ if not sysconfig.python_build:
|
|
# building third party extensions
|
|
self.library_dirs.append(sysconfig.get_config_var('LIBDIR'))
|
|
else:
|