7439694833
[Thomas: - use $(INSTALL) instead of install - add AR and RANLIB variables in the local makefiles, so that the cross toolchain ar and ranlib utilities are used instead of the native ones. - move the init script initialization to the EXIM_INSTALL_INIT_SYSV variable. - Use parenthesis instead of curly braces to reference TARGET_DIR.] Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
24 lines
800 B
Diff
24 lines
800 B
Diff
buildconfig is meant to be executed on the host, so it has to be compiled
|
|
using $(HOSTCC), not $(CC).
|
|
|
|
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
|
|
---
|
|
OS/Makefile-Base | 4 ++--
|
|
1 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/OS/Makefile-Base b/OS/Makefile-Base
|
|
index 29a6ad3..420ba60 100644
|
|
--- a/OS/Makefile-Base
|
|
+++ b/OS/Makefile-Base
|
|
@@ -114,8 +114,8 @@ allexim: config.h $(EXIM_MONITOR) exicyclog exinext exiwhat \
|
|
|
|
# Targets for special-purpose configuration header builders
|
|
buildconfig: buildconfig.c
|
|
- @echo "$(CC) buildconfig.c"
|
|
- $(FE)$(CC) $(CFLAGS) $(INCLUDE) -o buildconfig buildconfig.c $(LIBS)
|
|
+ @echo "$(HOSTCC) buildconfig.c"
|
|
+ $(FE)$(HOSTCC) $(HOSTCFLAGS) $(INCLUDE) -o buildconfig buildconfig.c $(LIBS)
|
|
|
|
|
|
# Target for the exicyclog utility script
|