886eca58cd
Note that this package builds and bundles a number of libraries, such as GLEW and Irrlicht. We are not interested in doing non-upstreamable changes, so it is not desirable to modify this choice in any way. In addition, Supertuxkart builds a version of the angelscript interpreter. If a compatible version of angelscript is installed on the system, it's possible to use it. [Peter: DOS newlines for 0002 patch, tweak comment header] Signed-off-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
35 lines
1.4 KiB
Diff
35 lines
1.4 KiB
Diff
From 73bed675202cf1f1c748540a4363d7d99e161dca Mon Sep 17 00:00:00 2001
|
|
From: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
|
|
Date: Thu, 9 Jun 2016 18:58:51 -0300
|
|
Subject: [PATCH 1/2] irrlicht: Get rid of unprefixed cflags
|
|
|
|
Cross-building requires proper include paths. This commit
|
|
removes the unprefixed -I/usr/X11R6/include in irrlicht cflags.
|
|
|
|
Signed-off-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
|
|
---
|
|
Fix sent upstream as part of pull:
|
|
https://github.com/supertuxkart/stk-code/pull/2554
|
|
|
|
lib/irrlicht/CMakeLists.txt | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/lib/irrlicht/CMakeLists.txt b/lib/irrlicht/CMakeLists.txt
|
|
index 46d54008c291..5f4975e3a6f9 100644
|
|
--- a/lib/irrlicht/CMakeLists.txt
|
|
+++ b/lib/irrlicht/CMakeLists.txt
|
|
@@ -25,8 +25,8 @@ elseif(MINGW)
|
|
add_definitions(-D_IRR_STATIC_LIB_)
|
|
add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff
|
|
else()
|
|
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing -I/usr/X11R6/include")
|
|
- set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing -I/usr/X11R6/include")
|
|
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
|
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
|
|
if(CMAKE_COMPILER_IS_GNUCC)
|
|
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fexpensive-optimizations")
|
|
endif()
|
|
--
|
|
2.9.0
|
|
|