bdef0f00f9
Signed-off-by: Christian Stewart <christian@paral.in> [Atul: - Updated the default to empty. - Updated the license to GPLv2. - Used patches instead of SED commands. - CC and LD are replaced by TARGET_CC and TARGET_LD.] Signed-off-by: Atul Singh <atul.singh.mandla@rockwellcollins.com> [yann.morin.1998@free.fr: - drop the headers_install command - instead, instruct the kernel to install them - add patches 0002..0004 - properly build the host tools - don't depend on the aufs extension, for kernel already patched - fix comment] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> [Thomas: - Remove the patch 0004-no-override-readdir64.patch, since it no longer applies to the latest version of aufs-util. Instead, add a post-patch hook that tweaks the Makefile to remove the problematic rdu64.o from the build process. - Use directly the kernel headers from the kernel source tree, rather than having to install them. This only requires a minor trick to define "__user" to empty.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
19 lines
671 B
Diff
19 lines
671 B
Diff
install: do not strip libs when installing
|
|
|
|
We want unstripped binaries in staging; stripping is done by Buildroot
|
|
as a whole in target-finalize if needed, anyway.
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
|
|
diff --git a/libau/Makefile b/libau/Makefile
|
|
--- a/libau/Makefile
|
|
+++ b/libau/Makefile
|
|
@@ -37,7 +37,6 @@
|
|
ln -sf $< $@
|
|
${LibSo}.${LibSoMajor}: ${LibSo}.${LibSoMajor}.${LibSoMinor}
|
|
ln -sf $< $@
|
|
-${LibSo}.${LibSoMajor}.${LibSoMinor}: override LDFLAGS += -s
|
|
${LibSo}.${LibSoMajor}.${LibSoMinor}: override LDLIBS += -ldl -lpthread
|
|
${LibSo}.${LibSoMajor}.${LibSoMinor}: ${LibSoObj}
|
|
${CC} --shared -Wl,-soname,${LibSo}.${LibSoMajor} ${LDFLAGS} \
|