2a23bd9eff
Following the removal of a number of patches in commit
b37e4a5f56
("package/python3: drop
unnecessary patches"), this commit renumbers the renaming patches, and
refreshes them as well so they apply cleanly with "git am".
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
34 lines
871 B
Diff
34 lines
871 B
Diff
From 1bf575c16a957dfc5ee6913b462d24a4e882698e Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
Date: Sat, 18 Aug 2018 10:54:56 +0200
|
|
Subject: [PATCH] Add an option to disable uuid module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
configure.ac | 9 +++++++++
|
|
1 file changed, 9 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index bd18ebe7582..6205e6782cf 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4318,6 +4318,15 @@ if test "$CURSES" = "no"; then
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _curses _curses_panel"
|
|
fi
|
|
|
|
+AC_SUBST(UUID)
|
|
+AC_ARG_ENABLE(uuid,
|
|
+ AS_HELP_STRING([--disable-uuid], [disable uuid]),
|
|
+ [ UUID="${enableval}" ], [ UUID=yes ])
|
|
+
|
|
+if test "$UUID" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _uuid"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
--
|
|
2.44.0
|
|
|