6b86c9335f
Other changes: - Drop patch 0003-hw-usb-host-libusb.c-fix-build-with-kernel-5.0.patch as it is part of 6.0.0. - Rename 0004-meson-add-tests-option.patch to 0003-meson-add-tests-option.patch and refresh it for 6.0.0 Signed-off-by: Adam Duskett <aduskett@rivian.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
95 lines
3.0 KiB
Diff
95 lines
3.0 KiB
Diff
From c24f6cc8f847a4f90cd8fe0f94604862c5ac4a5e Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@gmail.com>
|
|
Date: Mon, 21 Dec 2020 22:12:14 +0100
|
|
Subject: [PATCH] meson: add tests option
|
|
|
|
tests/fp/fp-bench.c use fenv.h that is not always provided
|
|
by the libc (uClibc).
|
|
|
|
To workaround this issue, add an new meson option to
|
|
disable tests while building Qemu.
|
|
|
|
Fixes:
|
|
http://autobuild.buildroot.net/results/53f5d8baa994d599b9da013ee643b82353366ec3/build-end.log
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
Refresh for 6.0.0
|
|
---
|
|
configure | 7 +++++++
|
|
meson.build | 5 ++++-
|
|
meson_options.txt | 2 ++
|
|
3 files changed, 13 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure b/configure
|
|
index 18c26e0389..7cceae4418 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -460,6 +460,7 @@ meson=""
|
|
ninja=""
|
|
skip_meson=no
|
|
gettext="auto"
|
|
+tests="auto"
|
|
fuse="auto"
|
|
fuse_lseek="auto"
|
|
multiprocess="auto"
|
|
@@ -1549,6 +1550,10 @@ for opt do
|
|
;;
|
|
--disable-libdaxctl) libdaxctl=no
|
|
;;
|
|
+ --disable-tests) tests="disabled"
|
|
+ ;;
|
|
+ --enable-tests) tests="enabled"
|
|
+ ;;
|
|
--enable-fuse) fuse="enabled"
|
|
;;
|
|
--disable-fuse) fuse="disabled"
|
|
@@ -1915,6 +1920,7 @@ disabled with --disable-FEATURE, default is enabled if available
|
|
xkbcommon xkbcommon support
|
|
rng-none dummy RNG, avoid using /dev/(u)random and getrandom()
|
|
libdaxctl libdaxctl support
|
|
+ tests build tests
|
|
fuse FUSE block device export
|
|
fuse-lseek SEEK_HOLE/SEEK_DATA support for FUSE exports
|
|
multiprocess Out of process device emulation support
|
|
@@ -6422,6 +6428,7 @@ NINJA=$ninja $meson setup \
|
|
-Dzstd=$zstd -Dseccomp=$seccomp -Dvirtfs=$virtfs -Dcap_ng=$cap_ng \
|
|
-Dattr=$attr -Ddefault_devices=$default_devices \
|
|
-Ddocs=$docs -Dsphinx_build=$sphinx_build -Dinstall_blobs=$blobs \
|
|
+ -Dtests=$tests \
|
|
-Dvhost_user_blk_server=$vhost_user_blk_server -Dmultiprocess=$multiprocess \
|
|
-Dfuse=$fuse -Dfuse_lseek=$fuse_lseek -Dguest_agent_msi=$guest_agent_msi \
|
|
$(if test "$default_features" = no; then echo "-Dauto_features=disabled"; fi) \
|
|
diff --git a/meson.build b/meson.build
|
|
index e3386196ba..7f4efdc347 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -2381,7 +2381,10 @@ subdir('scripts')
|
|
subdir('tools')
|
|
subdir('pc-bios')
|
|
subdir('docs')
|
|
-subdir('tests')
|
|
+if get_option('tests').enabled()
|
|
+ subdir('tests')
|
|
+endif
|
|
+
|
|
if gtk.found()
|
|
subdir('po')
|
|
endif
|
|
diff --git a/meson_options.txt b/meson_options.txt
|
|
index f6f64785fe..81bffbfe87 100644
|
|
--- a/meson_options.txt
|
|
+++ b/meson_options.txt
|
|
@@ -111,6 +111,8 @@ option('fuse_lseek', type : 'feature', value : 'auto',
|
|
|
|
option('vhost_user_blk_server', type: 'feature', value: 'auto',
|
|
description: 'build vhost-user-blk server')
|
|
+option('tests', type : 'feature', value : 'auto',
|
|
+ description: 'Tests build support')
|
|
option('virtfs', type: 'feature', value: 'auto',
|
|
description: 'virtio-9p support')
|
|
option('virtiofsd', type: 'feature', value: 'auto',
|
|
--
|
|
2.29.2
|
|
|