kumquat-buildroot/package/modutils/modutils.patch
Eric Andersen d5b0e08e9d http://bugs.uclibc.org/view.php?id=178
This patch provides modutils and module-init-tools. I know busybox can load
modules, but modinfo may also be very useful for kernel/driver debugging
purposes.

I have managed binaries concurrency between modutils and module-init-tools, but
I'm not sure this is the best way to do it...

Thanks for your work.
2005-06-09 09:46:12 +00:00

25 lines
959 B
Diff

--- _modutils-2.4.26/Makefile.in 2005-02-01 12:41:39.000000000 +0100
+++ modutils-2.4.26/Makefile.in 2005-02-01 12:39:18.000000000 +0100
@@ -3,7 +3,7 @@
include Makefile.common
TARGETS = all install-bin clean distclean realclean dep depend
-SUBDIRS = util obj insmod genksyms depmod @kerneld_SUBDIR@
+SUBDIRS = util obj insmod depmod @kerneld_SUBDIR@
ifneq (@kerneld_SUBDIR@,)
SUBDIRS += man_kerneld
endif
--- _modutils-2.4.26/insmod/Makefile.in 2003-10-27 05:42:07.000000000 +0100
+++ modutils-2.4.26/insmod/Makefile.in 2005-02-01 12:39:40.000000000 +0100
@@ -126,10 +126,6 @@
$(MKDIR) $(DESTDIR)$(sbindir); \
$(INSTALL) $(STRIP) $$i $(DESTDIR)$(sbindir); done;
set -e; \
- for i in $(srcdir)/insmod_ksymoops_clean $(srcdir)/kernelversion; do \
- $(MKDIR) $(DESTDIR)$(sbindir); \
- $(INSTALL) $$i $(DESTDIR)$(sbindir); done;
- set -e; \
for i in $(COMB); do \
ln -sf insmod $(DESTDIR)$(sbindir)/$$i; \
(test "$(insmod_static)" = yes && \