5ad021da2a
Add two patches to fix musl build and one patch to make the package autoreconfigurable. The first patch adds 'foreign' to 'AUTOMAKE_OPTIONS' to make the package autoreconfigurable. The second patch avoids the redefinition of wchar_t by using autoconf to check for the type wchar_t. Patching configure.ac requires to set AUTORECONF = YES and add a post extract hook to create some missing files needed by autorefonf. The third patch adds missing header include of <linux/params.h> needed for the macro EXEC_PAGESIZE defined in the Linux Kernel headers. All patches send upstream: https://sourceforge.net/p/ipmitool/mailman/message/35004711/ https://sourceforge.net/p/ipmitool/mailman/message/35007331/ https://sourceforge.net/p/ipmitool/mailman/message/35007330/ Fixes: http://autobuild.buildroot.net/results/75f/75fd6f1be0271bb15078c62f3effdbb67ac07427/ http://autobuild.buildroot.net/results/cac/cacf8179a9c8142eef69562462d3c3b0b20c2879/ http://autobuild.buildroot.net/results/c10/c1045882947ff7150c750088ae1981bd99134c54/ http://autobuild.buildroot.net/results/6a7/6a770f8a3dddb15ba4d95555e74b198799278dcf/ .. and more. Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From 661095378b74df564bc621ced4db72b688d87399 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
|
|
Date: Sat, 2 Apr 2016 19:47:21 +0200
|
|
Subject: [PATCH 3/3] Add missing linux/param.h header include
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Fixes the following build failure under musl:
|
|
|
|
imbapi.c: In function 'MapPhysicalMemory':
|
|
imbapi.c:109:19: error: 'EXEC_PAGESIZE' undeclared (first use in this function)
|
|
# define PAGESIZE EXEC_PAGESIZE
|
|
|
|
Upstream status: Pending
|
|
https://sourceforge.net/p/ipmitool/mailman/message/35007330/
|
|
|
|
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
|
|
---
|
|
src/plugins/imb/imbapi.c | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/src/plugins/imb/imbapi.c b/src/plugins/imb/imbapi.c
|
|
index 899c47a..8a6421d 100644
|
|
--- a/src/plugins/imb/imbapi.c
|
|
+++ b/src/plugins/imb/imbapi.c
|
|
@@ -95,6 +95,9 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
#include <stdlib.h>
|
|
#include <fcntl.h>
|
|
#include <string.h>
|
|
+#ifdef __linux__
|
|
+#include <linux/param.h>
|
|
+#endif
|
|
#endif
|
|
#include "imbapi.h"
|
|
#include <asm/socket.h>
|
|
--
|
|
2.8.0
|
|
|