66a3f7a240
Commit 95f9a5c3df
fixed the static
linking issue of uboot-tools mkimage against OpenSSL, but in the
process broke the dynamic linking case. This commit adjusts the
uboot-tools patch to make sure both static and dynamic linking work.
An updated version of the patch has been submitted upstream.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
40 lines
1.3 KiB
Diff
40 lines
1.3 KiB
Diff
From 99bc38ac6ebdd3b5d741cb9e50d842fa13d409f7 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 12 May 2015 22:54:29 +0200
|
|
Subject: [PATCH] tools: use pkg-config when available to get SSL flags
|
|
|
|
Instead of hardcoding -lssl -lcrypto as the flags needed to build
|
|
mkimage with FIT signature enabled, use pkg-config when
|
|
available. This allows to properly support cases where static linking
|
|
is used, which requires linking with -lz, since OpenSSL uses zlib
|
|
internally.
|
|
|
|
We gracefully fallback on the previous behavior of hardcoding -lssl
|
|
-lcrypto if pkg-config is not available or fails with an error.
|
|
|
|
Patch submitted upstream at
|
|
http://lists.denx.de/pipermail/u-boot/2015-May/214489.html
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
tools/Makefile | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/tools/Makefile b/tools/Makefile
|
|
index 4bbb153..8ff9c2e 100644
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -122,7 +122,8 @@ endif
|
|
|
|
# MXSImage needs LibSSL
|
|
ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
|
|
-HOSTLOADLIBES_mkimage += -lssl -lcrypto
|
|
+HOSTLOADLIBES_mkimage += \
|
|
+ $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
|
|
endif
|
|
|
|
HOSTLOADLIBES_dumpimage := $(HOSTLOADLIBES_mkimage)
|
|
--
|
|
2.1.0
|
|
|