9d6da7a264
Policycoreutils was broken up into several packages, as such several changes needed to happen for this patch to work: - Remove patches 3, 4, and 5 as they no longer apply. - Refresh patches 1 and 2 to work with version 2.7 - Remove semodule_${deps,expand,link,package} and sestatus from the makedirs in the mk file. - Remove restorecond from the make and config file. (Seperate package) - Remove Audit2allow from the make and config file. (In a different package) - Remove the package sepolgen - Add the package selinux-python - Add the package restorecond - Add the package semodule-utils - Add the relevant Config.in.legacy options into the menu. Because these are utilities that work on top of python, the older versions of these utilites still work, and as such this should be a single patch. Signed-off-by: Adam Duskett <Adamduskett@outlook.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
From 85763549c53b2907dab094163f1404b2233f8029 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <Adamduskett@outlook.com>
|
|
Date: Mon, 9 Oct 2017 16:51:20 -0400
|
|
Subject: [PATCH] Add DESTDIR to setfiles
|
|
|
|
The addition of this patch makes the use of DESTDIR
|
|
mandatory as there are conditional checks which would fail if it's not
|
|
defined.
|
|
|
|
This patch was updated from the patch provided by Niranjan Reddy to
|
|
accomodate version 2.5
|
|
|
|
Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
|
|
Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com>
|
|
Signed-off-by: Adam Duskett <AdamDuskett@outlook.com>
|
|
---
|
|
setfiles/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setfiles/Makefile b/setfiles/Makefile
|
|
index c08e2dd..36c0638 100644
|
|
--- a/setfiles/Makefile
|
|
+++ b/setfiles/Makefile
|
|
@@ -3,7 +3,7 @@ PREFIX ?= $(DESTDIR)/usr
|
|
SBINDIR ?= $(DESTDIR)/sbin
|
|
MANDIR = $(PREFIX)/share/man
|
|
LIBDIR ?= $(PREFIX)/lib
|
|
-AUDITH ?= $(shell test -f /usr/include/libaudit.h && echo y)
|
|
+AUDITH ?= $(shell test -f $(DESTDIR)/include/libaudit.h && echo y)
|
|
|
|
ABORT_ON_ERRORS=$(shell grep "^\#define ABORT_ON_ERRORS" setfiles.c | awk -S '{ print $$3 }')
|
|
|
|
--
|
|
2.13.6
|
|
|