68d0aede59
https://sourceware.org/pipermail/libc-alpha/2022-February/136040.html - Remove upstreamed patch 0001. Patches to localedef are not upstream. - allow to use optimization CFLAGS (not CPPFLAGS) which are nowadays supported by upstream (except nios2) - enable support for or1k, which is now included upstream - runtime tested with qemu-system for aarch64/arm/microblaze/mips/mips64/nios2/ or1k/powerpc/powerpc64/powerpc64le/riscv32/riscv64/s390x/sh4/sparc64/x86/x86_64 Since only a single version is supported (no csky fork any more), move the hash file out of the version directory. Also, make a symlink from the localedef to the glibc hash file rather than copying it. Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Reviewed-by: Petr Vorel <petr.vorel@gmail.com> Tested-by: Petr Vorel <petr.vorel@gmail.com> [Arnout: make localedef.hash a symlink] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
66 lines
2.4 KiB
Diff
66 lines
2.4 KiB
Diff
From 442e9a3f262c49cf61f9e7bdf12882f0a427666b Mon Sep 17 00:00:00 2001
|
|
From: Michael Olbrich <m.olbrich@pengutronix.de>
|
|
Date: Mon, 21 May 2018 16:45:02 +0200
|
|
Subject: [PATCH] HACK: only build and install localedef
|
|
|
|
Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
|
|
|
|
Upstream: https://git.pengutronix.de/cgit/ptxdist/plain/patches/localedef-glibc-2.27/0001-HACK-only-build-and-install-localedef.patch?id=47116f66f411d4dadfce42c2fdd6d41b351ccfd4
|
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
|
---
|
|
Rules | 14 ++++++++++----
|
|
locale/Makefile | 6 +++---
|
|
2 files changed, 13 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/Rules b/Rules
|
|
index b1137afe71..2aeac31922 100644
|
|
--- a/Rules
|
|
+++ b/Rules
|
|
@@ -216,10 +216,16 @@ binaries-shared-notests = $(filter-out $(binaries-pie) $(binaries-static), \
|
|
$(binaries-all-notests))
|
|
|
|
ifneq "$(strip $(binaries-shared-notests))" ""
|
|
-$(addprefix $(objpfx),$(binaries-shared-notests)): %: %.o \
|
|
- $(sort $(filter $(common-objpfx)lib%,$(link-libc))) \
|
|
- $(addprefix $(csu-objpfx),start.o) $(+preinit) $(+postinit)
|
|
- $(+link)
|
|
+$(addprefix $(objpfx),$(binaries-shared-notests)): %: %.o
|
|
+ $(CC) -o $@ \
|
|
+ $(sysdep-LDFLAGS) $(LDFLAGS) $(LDFLAGS-$(@F)) \
|
|
+ $(combreloc-LDFLAGS) $(relro-LDFLAGS) $(hashstyle-LDFLAGS) \
|
|
+ $(filter-out $(addprefix $(csu-objpfx),start.o \
|
|
+ $(start-installed-name))\
|
|
+ $(+preinit) \
|
|
+ $(link-extra-libs) \
|
|
+ $(common-objpfx)libc% $(+postinit),$^) \
|
|
+ $(link-extra-libs)
|
|
endif
|
|
|
|
ifneq "$(strip $(binaries-shared-tests))" ""
|
|
diff --git a/locale/Makefile b/locale/Makefile
|
|
index b7c60681fa..de4cf4003f 100644
|
|
--- a/locale/Makefile
|
|
+++ b/locale/Makefile
|
|
@@ -33,15 +33,15 @@ categories = ctype messages monetary numeric time paper name \
|
|
address telephone measurement identification collate
|
|
aux = $(categories:%=lc-%) $(categories:%=C-%) SYS_libc C_name \
|
|
xlocale localename global-locale coll-lookup
|
|
-others = localedef locale
|
|
+others = localedef
|
|
#others-static = localedef locale
|
|
-install-bin = localedef locale
|
|
+install-bin = localedef
|
|
extra-objs = $(localedef-modules:=.o) $(localedef-aux:=.o) \
|
|
$(locale-modules:=.o) $(lib-modules:=.o)
|
|
generated += C-translit.h
|
|
before-compile += $(objpfx)C-translit.h
|
|
|
|
-extra-libs = libBrokenLocale
|
|
+#extra-libs = libBrokenLocale
|
|
extra-libs-others = $(extra-libs)
|
|
|
|
libBrokenLocale-routines = broken_cur_max
|
|
--
|
|
2.33.0
|
|
|