009407e6be
* Convert binutils to a proper autotargets package
* Add version 2.21 and drop version 2.17
* Hook up packaged binutils for target gcc
* Build tools are on HOST_DIR now so change it
* Move cross/host gcc to HOST_DIR
* Drop kludge from commit 3c77bab2ee
This is fixed in the next commit "gcc: install copies of libgcc,
libstdc++ and libgcj to the sysroot" - tested for arm & x86_64
targets.
* TARGET_CROSS now pointed to HOST_DIR too
[Peter: Config.in tweaks]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
33 lines
1.5 KiB
Diff
33 lines
1.5 KiB
Diff
diff -u binutils-2.18-orig/configure binutils-2.18/configure
|
|
--- binutils-2.18-orig/configure 2007-08-06 16:29:40.000000000 -0400
|
|
+++ binutils-2.18/configure 2007-09-27 22:41:51.000000000 -0400
|
|
@@ -6125,10 +6125,10 @@
|
|
*" texinfo "*) MAKEINFO='$$r/$(BUILD_SUBDIR)/texinfo/makeinfo/makeinfo' ;;
|
|
*)
|
|
|
|
- # For an installed makeinfo, we require it to be from texinfo 4.4 or
|
|
+ # For an installed makeinfo, we require it to be from texinfo 4.6 or
|
|
# higher, else we use the "missing" dummy.
|
|
if ${MAKEINFO} --version \
|
|
- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
|
|
+ | egrep 'texinfo[^0-9]*(4\.([6-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
|
|
:
|
|
else
|
|
MAKEINFO="$MISSING makeinfo"
|
|
diff -u binutils-2.18-orig/configure.ac binutils-2.18/configure.ac
|
|
--- binutils-2.18-orig/configure.ac 2007-08-28 16:24:26.000000000 -0400
|
|
+++ binutils-2.18/configure.ac 2007-09-27 22:41:00.000000000 -0400
|
|
@@ -2400,10 +2400,10 @@
|
|
*" texinfo "*) MAKEINFO='$$r/$(BUILD_SUBDIR)/texinfo/makeinfo/makeinfo' ;;
|
|
*)
|
|
changequote(,)
|
|
- # For an installed makeinfo, we require it to be from texinfo 4.4 or
|
|
+ # For an installed makeinfo, we require it to be from texinfo 4.6 or
|
|
# higher, else we use the "missing" dummy.
|
|
if ${MAKEINFO} --version \
|
|
- | egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|[5-9])' >/dev/null 2>&1; then
|
|
+ | egrep 'texinfo[^0-9]*(4\.([6-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null 2>&1; then
|
|
:
|
|
else
|
|
MAKEINFO="$MISSING makeinfo"
|