52a142a631
The goal is to be able to use savedefconfig to generate minimal defconfig files. Four of our patches are removed since the modifications have been merged upstream. The new nconf configuration utility has appeared. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
30 lines
1.0 KiB
Diff
30 lines
1.0 KiB
Diff
---
|
|
Makefile | 14 ++++++++++----
|
|
1 file changed, 10 insertions(+), 4 deletions(-)
|
|
|
|
Index: config.new/Makefile
|
|
===================================================================
|
|
--- config.new.orig/Makefile
|
|
+++ config.new/Makefile
|
|
@@ -199,10 +199,16 @@
|
|
gconf-objs := gconf.o kconfig_load.o zconf.tab.o
|
|
endif
|
|
|
|
-clean-files := lkc_defs.h qconf.moc .tmp_qtcheck \
|
|
- .tmp_gtkcheck zconf.tab.c lex.zconf.c zconf.hash.c gconf.glade.h
|
|
-clean-files += mconf qconf gconf nconf
|
|
-clean-files += config.pot linux.pot
|
|
+clean-files := lkc_defs.h qconf.moc .tmp_qtcheck \
|
|
+ .tmp_gtkcheck zconf.tab.c lex.zconf.c zconf.hash.c gconf.glade.h
|
|
+clean-files += config.pot linux.pot
|
|
+clean-files += conf $(conf-objs)
|
|
+clean-files += mconf $(mconf-objs)
|
|
+clean-files += nconf $(nconf-objs)
|
|
+clean-files += qconf qconf.o
|
|
+clean-files += gconf gconf.o
|
|
+clean-files += kconfig_load.o zconf.tab.o
|
|
+clean-files += $(kxgettext-objs)
|
|
|
|
# Check that we have the required ncurses stuff installed for lxdialog (menuconfig)
|
|
PHONY += $(obj)/dochecklxdialog
|