30 lines
766 B
Diff
30 lines
766 B
Diff
--- ruby-1.8.3/configure.in.orig 2005-11-29 11:18:27.000000000 +0100
|
|
+++ ruby-1.8.3/configure.in 2005-11-29 11:19:46.000000000 +0100
|
|
@@ -529,7 +529,25 @@
|
|
fi
|
|
|
|
AC_FUNC_GETPGRP
|
|
-AC_FUNC_SETPGRP
|
|
+
|
|
+dnl AC_FUNC_SETPGRP does not work if cross compiling
|
|
+dnl Instead, assume we will have a prototype for setpgrp if cross compiling.
|
|
+if test "$cross_compiling" = no; then
|
|
+ AC_FUNC_SETPGRP
|
|
+else
|
|
+ AC_CACHE_CHECK([whether setpgrp takes no argument], ac_cv_func_setpgrp_void,
|
|
+ [AC_TRY_COMPILE([
|
|
+#include <unistd.h>
|
|
+], [
|
|
+ if (setpgrp(1,1) == -1)
|
|
+ exit (0);
|
|
+ else
|
|
+ exit (1);
|
|
+], ac_cv_func_setpgrp_void=no, ac_cv_func_setpgrp_void=yes)])
|
|
+if test $ac_cv_func_setpgrp_void = yes; then
|
|
+ AC_DEFINE(SETPGRP_VOID, 1)
|
|
+fi
|
|
+fi
|
|
|
|
AC_C_BIGENDIAN
|
|
AC_C_CONST
|