24b27158cf
MySQL 5.1.47 is affected by a bug in one test called the "ABI check", which does not work with recent gcc versions. This bug is referenced as http://bugs.mysql.com/bug.php?id=52514 in MySQL bug tracker. Since it has been fixed in newer versions of MySQL, we simply bump the version to the latest available in the 5.1.x series. The patches have not changed, they have only been refreshed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
22 lines
682 B
Diff
22 lines
682 B
Diff
Tell MySQL to use the new readline interface even when an external
|
|
readline is being used.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
---
|
|
configure.in | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
Index: mysql-5.1.53/configure.in
|
|
===================================================================
|
|
--- mysql-5.1.53.orig/configure.in
|
|
+++ mysql-5.1.53/configure.in
|
|
@@ -2689,6 +2689,7 @@
|
|
# this way we avoid linking commercial source with GPL readline
|
|
readline_link="-lreadline"
|
|
want_to_use_readline="yes"
|
|
+ AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
|
|
elif [test "$mysql_cv_libedit_interface" = "yes"]
|
|
then
|
|
# Use libedit
|