9217101241
(aka fix the fix) Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
50 lines
1.4 KiB
Diff
50 lines
1.4 KiB
Diff
From dbf8fd1d097420d02f0603155ca81fcc7e232a0a Mon Sep 17 00:00:00 2001
|
|
From: Lionel Landwerlin <llandwerlin@gmail.com>
|
|
Date: Sun, 7 Nov 2010 21:45:19 +0100
|
|
Subject: [PATCH] Add -lm flag when nedded
|
|
|
|
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
|
|
---
|
|
configure.in | 14 ++++++++++++++
|
|
src/media/Makefile.am | 2 +-
|
|
2 files changed, 15 insertions(+), 1 deletions(-)
|
|
|
|
diff --git a/configure.in b/configure.in
|
|
index 78c842d..aa608d4 100644
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -533,6 +533,20 @@ AM_CONDITIONAL(DIRECTFB_BUILD_PURE_VOODOO, test "$DIRECTFB_BUILD_PURE_VOODOO" =
|
|
|
|
AC_SUBST(DEP_VOODOO)
|
|
|
|
+dnl If we're not building a pure voodoo lib, we need the sqrt symbol
|
|
+dnl for src/media/idirectfbfont.c
|
|
+MEDIALIB=""
|
|
+if test "$enable_pure_voodoo" = "no"; then
|
|
+ AC_CHECK_LIB(m, sqrt,
|
|
+ MEDIALIB="-lm",
|
|
+ AC_MSG_ERROR([
|
|
+*** DirectFB requires libm.]))
|
|
+ if test "$enable_shared" = "yes"; then
|
|
+ DYNLIB+=" $MEDIALIB"
|
|
+ AC_SUBST(DYNLIB)
|
|
+ fi
|
|
+fi
|
|
+AC_SUBST(MEDIALIB)
|
|
|
|
AM_CONDITIONAL(ENABLE_MULTI, test "$enable_multi" = "yes")
|
|
|
|
diff --git a/src/media/Makefile.am b/src/media/Makefile.am
|
|
index 1a39a25..a4bdb10 100644
|
|
--- a/src/media/Makefile.am
|
|
+++ b/src/media/Makefile.am
|
|
@@ -35,4 +35,4 @@ libdirectfb_media_la_SOURCES = \
|
|
idirectfbdatabuffer_file.c \
|
|
idirectfbdatabuffer_memory.c \
|
|
idirectfbdatabuffer_streamed.c
|
|
-
|
|
+libdirectfb_media_la_LDFLAGS = $(MEDIALIB)
|
|
--
|
|
1.7.2.3
|
|
|