kumquat-buildroot/package/libgtk3/0001-disable-atk-bridge.patch
Francois Perrad 40866ae0ce package/libgtk3: bump to version 3.24.36
Fixes:
http://autobuild.buildroot.net/results/37c/37c7db88622c93f1c58aff7431b638143ae741d3/

As the 3.24.5 release tarball was missing a file:
https://gitlab.gnome.org/GNOME/gtk/-/issues/5355

Switch to meson infra and remove autotools specific patches as the autotools
support has been dropped:

https://download.gnome.org/sources/gtk+/3.24/gtk%2B-3.24.36.news

host-libgtk3 is a hack which builds only gtk-update-icon-cache
host-libgtk3 is used by libgtk3 & adwaita-icon-theme

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2023-02-07 22:26:57 +01:00

42 lines
1.4 KiB
Diff

Remove atk-bridge support.
atk-bridge doesn't seem useful for now in Buildroot and requires to
add two new packages just for it: at-spi2-core and at-spi2-atk.
Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
--- a/gtk/a11y/gtkaccessibility.c
+++ b/gtk/a11y/gtkaccessibility.c
@@ -37,10 +37,6 @@
#include <gtk/gtktogglebutton.h>
#include <gtk/gtkaccessible.h>
-#ifdef GDK_WINDOWING_X11
-#include <atk-bridge.h>
-#endif
-
static gboolean gail_focus_watcher (GSignalInvocationHint *ihint,
guint n_param_values,
const GValue *param_values,
@@ -988,9 +984,5 @@ _gtk_accessibility_init (void)
_gtk_accessibility_override_atk_util ();
do_window_event_initialization ();
-#ifdef GDK_WINDOWING_X11
- atk_bridge_adaptor_init (NULL, NULL);
-#endif
-
atk_misc_instance = g_object_new (GTK_TYPE_MISC_IMPL, NULL);
}
--- a/meson.build
+++ b/meson.build
@@ -564,7 +564,7 @@ if x11_enabled
xfixes_dep = dependency('xfixes', required: false)
xcomposite_dep = dependency('xcomposite', required: false)
fontconfig_dep = dependency('fontconfig', fallback: ['fontconfig', 'fontconfig_dep'])
- atkbridge_dep = dependency('atk-bridge-2.0', version: at_spi2_atk_req)
+ atkbridge_dep = dependency('atk-bridge-2.0', version: at_spi2_atk_req, required: false)
backend_immodules += ['xim']