d47fa52df5
- Switch to github to get latest release - Drop first and second patches (already in version) - Drop third patch (not needed anymore) - Drop BSD-3-Clause and COPYING.slirpvde (slirpvde removed witheda0a1bc1d
14e1c9e06f
) - python removed with2c57c25075
- kernel switch removed withb196ecd5b7
- parallel build has been fixed with7dd9ed46d5
- openssl has been replaced by wolfssl with8599321526
https://github.com/virtualsquare/vde-2/releases/tag/v2.3.3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
43 lines
1.2 KiB
Makefile
43 lines
1.2 KiB
Makefile
################################################################################
|
|
#
|
|
# vde2
|
|
#
|
|
################################################################################
|
|
|
|
VDE2_VERSION = 2.3.3
|
|
VDE2_SITE = $(call github,virtualsquare,vde-2,v$(VDE2_VERSION))
|
|
VDE2_LICENSE = GPL-2.0+, LGPL-2.1+
|
|
VDE2_LICENSE_FILES = COPYING COPYING.libvdeplug
|
|
VDE2_CPE_ID_VENDOR = vde_project
|
|
VDE2_CPE_ID_PRODUCT = vde
|
|
VDE2_INSTALL_STAGING = YES
|
|
|
|
# From git
|
|
VDE2_AUTORECONF = YES
|
|
|
|
# Reasons for enabling/disabling stuff:
|
|
# - tuntap is enabled in the hope we're using a recent-enough toolchain
|
|
# that does have if_tun.h (virtually everything these days)
|
|
# - cryptcab is disabled to not depend on wolfssl
|
|
# - pcap is disabled to not depend on libpcap
|
|
# - profiling is disabled because we do not want to debug/profile
|
|
#
|
|
# Note: disabled features can be added with corresponding dependencies
|
|
# in future commits.
|
|
VDE2_CONF_OPTS = \
|
|
--disable-cryptcab \
|
|
--disable-experimental \
|
|
--disable-pcap \
|
|
--disable-profile \
|
|
--enable-tuntap
|
|
|
|
HOST_VDE2_CONF_OPTS = \
|
|
--disable-cryptcab \
|
|
--disable-experimental \
|
|
--disable-pcap \
|
|
--disable-profile \
|
|
--enable-tuntap
|
|
|
|
$(eval $(autotools-package))
|
|
$(eval $(host-autotools-package))
|