c19cca0452
Now that we document _CPE_ID_VALID, and that it shall be used instead of setting a default value to one of the other _CPE_ID_* variables, change all of the existing packages to use it, to avoid any error when we later extend check-package to validate the sanity ofthe _CPE_ID_* variables. Mechanical change done within the reference container, running the new check in check-package, to report the CPE_ID errors: $ make check-package 2>/dev/null \ |awk '{ split($(1), a, ":"); fname = a[1] split($(2), a, "'\''"); val = a[2] new_var = $(8); gsub("_CPE_ID_.*", "_CPE_ID_VALID", new_var) printf("%s %s %s %s\n", fname, $(8), val, new_var) }' \ |while read fname var val new_var; do sed -r -i -e "s/${var}[[:space:]]*=[[:space:]]*${val}/${new_var} = YES/" "${fname}" done $ git diff -I'CPE_ID_(VENDOR|VALID)' [empty] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
16 lines
447 B
Makefile
16 lines
447 B
Makefile
################################################################################
|
|
#
|
|
# upx
|
|
#
|
|
################################################################################
|
|
|
|
UPX_VERSION = 4.2.1
|
|
UPX_SITE = https://github.com/upx/upx/releases/download/v$(UPX_VERSION)
|
|
UPX_SOURCE = upx-$(UPX_VERSION)-src.tar.xz
|
|
UPX_LICENSE = GPL-2.0+
|
|
UPX_LICENSE_FILES = COPYING
|
|
UPX_CPE_ID_VALID = YES
|
|
UPX_SUPPORTS_IN_SOURCE_BUILD = NO
|
|
|
|
$(eval $(host-cmake-package))
|