kumquat-buildroot/package/sdbus-cpp/sdbus-cpp.mk
Fabrice Fontaine faf371a476 package/sdbus-cpp: fix host build
cmake options were renamed by
0074c79e7f
resulting in the following host build failure since bump to version
2.0.0 in commit 0f5bb364c6:

/home/buildroot/autobuild/run/instance-1/output-1/build/host-sdbus-cpp-2.0.0/src/Proxy.cpp: In member function 'virtual sdbus::PendingAsyncCall sdbus::internal::Proxy::callMethodAsync(const sdbus::MethodCall&, sdbus::async_reply_handler, uint64_t)':
/home/buildroot/autobuild/run/instance-1/output-1/build/host-sdbus-cpp-2.0.0/src/Proxy.cpp:125:91: sorry, unimplemented: non-trivial designated initializers not supported
                                                                       , .floating = false });
                                                                                           ^
/home/buildroot/autobuild/run/instance-1/output-1/build/host-sdbus-cpp-2.0.0/src/Proxy.cpp:133:60: error: class template argument deduction failed:
     auto asyncCallInfoWeakPtr = std::weak_ptr{asyncCallInfo};
                                                            ^

Fixes: 0f5bb364c6
 - http://autobuild.buildroot.org/results/66668261d05203575658a243e02e78cf77018d8c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2024-05-08 18:33:05 +02:00

24 lines
773 B
Makefile

################################################################################
#
# sdbus-c++
#
################################################################################
SDBUS_CPP_VERSION = 2.0.0
SDBUS_CPP_SITE = $(call github,Kistler-Group,sdbus-cpp,v$(SDBUS_CPP_VERSION))
SDBUS_CPP_INSTALL_STAGING = YES
SDBUS_CPP_DEPENDENCIES = host-pkgconf systemd
SDBUS_CPP_LICENSE = LGPL-2.1+ with exception (headers)
SDBUS_CPP_LICENSE_FILES = COPYING COPYING-LGPL-Exception
# Host build for sdbus-c++-xml2cpp
HOST_SDBUS_CPP_DEPENDENCIES = host-pkgconf host-systemd
HOST_SDBUS_CPP_CONF_OPTS = \
-DSDBUSCPP_BUILD_CODEGEN=ON \
-DSDBUSCPP_BUILD_DOCS=OFF \
-DSDBUSCPP_BUILD_TESTS=OFF \
-DSDBUSCPP_BUILD_LIBSYSTEMD=OFF
$(eval $(cmake-package))
$(eval $(host-cmake-package))