kumquat-buildroot/package/python-rsa/python-rsa.mk
James Hilliard 9502fe2bb5 package/python-rsa: migrate to poetry core pep517 build backend
We need to migrate python-rsa to the pep517 poetry-core
backend as setuptools is not supported when building with a pep517
frontend.

This package currently builds using setuptools as we do not yet
use setuptools with a pep517 build frontend. The package contains
a setuptools fallback which only can be used when using setuptools
without a pep517 frontend as the pep517 frontend will only use the
build backend specified in the package pyproject.toml which is
poetry-core and not setuptools.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
2024-04-01 22:12:51 +02:00

17 lines
588 B
Makefile

################################################################################
#
# python-rsa
#
################################################################################
PYTHON_RSA_VERSION = 4.9
PYTHON_RSA_SOURCE = rsa-$(PYTHON_RSA_VERSION).tar.gz
PYTHON_RSA_SITE = https://files.pythonhosted.org/packages/aa/65/7d973b89c4d2351d7fb232c2e452547ddfa243e93131e7cfa766da627b52
PYTHON_RSA_SETUP_TYPE = pep517
PYTHON_RSA_LICENSE = Apache-2.0
PYTHON_RSA_LICENSE_FILES = LICENSE
PYTHON_RSA_CPE_ID_VALID = YES
PYTHON_RSA_DEPENDENCIES = host-python-poetry-core
$(eval $(python-package))