kumquat-buildroot/package/python-ml-dtypes/python-ml-dtypes.mk
James Hilliard 4b4ec03998 package/python-ml-dtypes: skip dependency check
This package pins overly strict numpy dependency versions apparently
for compatibility reasons that don't appear relevant to buildroot.

This package also appears to pin an overly strict setuptools version
for unclear reasons.

See:
https://github.com/jax-ml/ml_dtypes/blob/v0.3.2/pyproject.toml#L51-L55

To fix this lets just set the --skip-dependency-check build option and
ignore the build dependency version mismatches since they don't appear
to cause any build issues.

This error was introduced when we migrated setuptools to pep517 in
8937db8dd5.

Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/6888691520

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Tested-by: Julien Olivain <ju.o@free.fr>
[Romain: add gitlab-ci link]
Signed-off-by: Romain Naour <romain.naour@smile.fr>
2024-05-22 13:44:24 +02:00

20 lines
692 B
Makefile

################################################################################
#
# python-ml-dtypes
#
################################################################################
PYTHON_ML_DTYPES_VERSION = 0.3.2
PYTHON_ML_DTYPES_SOURCE = ml_dtypes-$(PYTHON_ML_DTYPES_VERSION).tar.gz
PYTHON_ML_DTYPES_SITE = https://files.pythonhosted.org/packages/39/7d/8d85fcba868758b3a546e6914e727abd8f29ea6918079f816975c9eecd63
PYTHON_ML_DTYPES_LICENSE = Apache-2.0
PYTHON_ML_DTYPES_LICENSE_FILES = LICENSE
PYTHON_ML_DTYPES_SETUP_TYPE = setuptools
PYTHON_ML_DTYPES_BUILD_OPTS = --skip-dependency-check
PYTHON_ML_DTYPES_DEPENDENCIES = \
host-python-numpy \
python-numpy
$(eval $(python-package))