c19cca0452
Now that we document _CPE_ID_VALID, and that it shall be used instead of setting a default value to one of the other _CPE_ID_* variables, change all of the existing packages to use it, to avoid any error when we later extend check-package to validate the sanity ofthe _CPE_ID_* variables. Mechanical change done within the reference container, running the new check in check-package, to report the CPE_ID errors: $ make check-package 2>/dev/null \ |awk '{ split($(1), a, ":"); fname = a[1] split($(2), a, "'\''"); val = a[2] new_var = $(8); gsub("_CPE_ID_.*", "_CPE_ID_VALID", new_var) printf("%s %s %s %s\n", fname, $(8), val, new_var) }' \ |while read fname var val new_var; do sed -r -i -e "s/${var}[[:space:]]*=[[:space:]]*${val}/${new_var} = YES/" "${fname}" done $ git diff -I'CPE_ID_(VENDOR|VALID)' [empty] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
42 lines
1.3 KiB
Makefile
42 lines
1.3 KiB
Makefile
################################################################################
|
|
#
|
|
# pugixml
|
|
#
|
|
################################################################################
|
|
|
|
PUGIXML_VERSION = 1.14
|
|
PUGIXML_SITE = https://github.com/zeux/pugixml/releases/download/v$(PUGIXML_VERSION)
|
|
PUGIXML_LICENSE = MIT
|
|
PUGIXML_LICENSE_FILES = LICENSE.md
|
|
PUGIXML_CPE_ID_VALID = YES
|
|
|
|
PUGIXML_INSTALL_STAGING = YES
|
|
|
|
ifeq ($(BR2_PACKAGE_PUGIXML_XPATH_SUPPORT),y)
|
|
PUGIXML_CONF_OPTS += -DPUGIXML_NO_XPATH=OFF
|
|
else
|
|
PUGIXML_CONF_OPTS += -DPUGIXML_NO_XPATH=ON
|
|
endif
|
|
|
|
ifeq ($(BR2_PACKAGE_PUGIXML_COMPACT),y)
|
|
PUGIXML_CONF_OPTS += -DPUGIXML_COMPACT=ON
|
|
else
|
|
PUGIXML_CONF_OPTS += -DPUGIXML_COMPACT=OFF
|
|
endif
|
|
|
|
# Pugixml will automatically enable 'long long' support on C++11 compilers,
|
|
# which means gcc 4.8+. As gcc always supports the 'long long' type,
|
|
# force-enable this option to support older gcc versions. See also:
|
|
# https://gcc.gnu.org/onlinedocs/gcc/Long-Long.html
|
|
PUGIXML_BUILD_DEFINES += PUGIXML_HAS_LONG_LONG
|
|
HOST_PUGIXML_BUILD_DEFINES += PUGIXML_HAS_LONG_LONG
|
|
|
|
PUGIXML_CONF_OPTS += -DPUGIXML_BUILD_DEFINES="$(subst $(space),;,$(PUGIXML_BUILD_DEFINES))"
|
|
|
|
HOST_PUGIXML_CONF_OPTS += \
|
|
-DBUILD_PKGCONFIG=ON \
|
|
-DPUGIXML_BUILD_DEFINES="$(subst $(space),;,$(HOST_PUGIXML_BUILD_DEFINES))"
|
|
|
|
$(eval $(cmake-package))
|
|
$(eval $(host-cmake-package))
|