0f5bbd4458
- License updated to match the PHP 3.01 license:5fc2d81806
- This bump will fix the following build failure raised since bump of php to version 8.3.4 in commite50460f9f1
: checking Check for supported PHP versions... configure: error: not supported. Need a PHP version >= 8.0.0 and < 8.3.0 (found 8.3.4) https://xdebug.org/updates#x_3_3_1 Fixes:e50460f9f1
- http://autobuild.buildroot.org/results/0209b522baec3c88a2060e79f805552db79b2c70 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
36 lines
1023 B
Makefile
36 lines
1023 B
Makefile
################################################################################
|
|
#
|
|
# php-xdebug
|
|
#
|
|
################################################################################
|
|
|
|
PHP_XDEBUG_VERSION = 3.3.1
|
|
PHP_XDEBUG_SOURCE = xdebug-$(PHP_XDEBUG_VERSION).tgz
|
|
PHP_XDEBUG_SITE = https://xdebug.org/files
|
|
PHP_XDEBUG_INSTALL_STAGING = YES
|
|
PHP_XDEBUG_LICENSE = Xdebug License (PHP-3.01-like)
|
|
PHP_XDEBUG_LICENSE_FILES = LICENSE
|
|
# phpize does the autoconf magic
|
|
PHP_XDEBUG_DEPENDENCIES = php host-autoconf
|
|
PHP_XDEBUG_CONF_OPTS = \
|
|
--enable-xdebug \
|
|
--with-php-config=$(STAGING_DIR)/usr/bin/php-config
|
|
|
|
define PHP_XDEBUG_PHPIZE
|
|
(cd $(@D); \
|
|
PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
|
|
PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
|
|
$(STAGING_DIR)/usr/bin/phpize)
|
|
endef
|
|
|
|
PHP_XDEBUG_PRE_CONFIGURE_HOOKS += PHP_XDEBUG_PHPIZE
|
|
|
|
ifeq ($(BR2_PACKAGE_ZLIB),y)
|
|
PHP_XDEBUG_CONF_OPTS += --with-xdebug-compression
|
|
PHP_XDEBUG_DEPENDENCIES += zlib
|
|
else
|
|
PHP_XDEBUG_CONF_OPTS += --without-xdebug-compression
|
|
endif
|
|
|
|
$(eval $(autotools-package))
|