f6b96fbd62
Removed all patches, they are included in this release. Release notes: https://lists.gnu.org/archive/html/info-gnu/2023-02/msg00011.html https://lists.gnu.org/archive/html/info-gnu/2022-10/msg00008.html https://lists.gnu.org/archive/html/info-gnu/2020-01/msg00004.html The COPYING license file has changed due to the switch from http:// to https:// URLs in the text. Signed-off-by: Bernd Kuhls <bernd@kuhls.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
31 lines
906 B
Makefile
31 lines
906 B
Makefile
################################################################################
|
|
#
|
|
# make
|
|
#
|
|
################################################################################
|
|
|
|
MAKE_VERSION = 4.4.1
|
|
MAKE_SOURCE = make-$(MAKE_VERSION).tar.lz
|
|
MAKE_SITE = $(BR2_GNU_MIRROR)/make
|
|
MAKE_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) host-pkgconf
|
|
MAKE_LICENSE = GPL-3.0+
|
|
MAKE_LICENSE_FILES = COPYING
|
|
MAKE_CPE_ID_VENDOR = gnu
|
|
|
|
MAKE_CONF_OPTS = --without-guile
|
|
|
|
# Disable the 'load' operation for static builds since it needs dlopen
|
|
ifeq ($(BR2_STATIC_LIBS),y)
|
|
MAKE_CONF_OPTS += --disable-load
|
|
endif
|
|
|
|
HOST_MAKE_DEPENDENCIES = host-pkgconf
|
|
HOST_MAKE_CONF_OPTS = --without-guile
|
|
|
|
# Configure host-make binary to be 'host-make' to ensure it isn't
|
|
# accidently used by packages when they invoke recursive / sub-make.
|
|
HOST_MAKE_CONF_OPTS += --program-prefix=host-
|
|
|
|
$(eval $(autotools-package))
|
|
$(eval $(host-autotools-package))
|