c19cca0452
Now that we document _CPE_ID_VALID, and that it shall be used instead of setting a default value to one of the other _CPE_ID_* variables, change all of the existing packages to use it, to avoid any error when we later extend check-package to validate the sanity ofthe _CPE_ID_* variables. Mechanical change done within the reference container, running the new check in check-package, to report the CPE_ID errors: $ make check-package 2>/dev/null \ |awk '{ split($(1), a, ":"); fname = a[1] split($(2), a, "'\''"); val = a[2] new_var = $(8); gsub("_CPE_ID_.*", "_CPE_ID_VALID", new_var) printf("%s %s %s %s\n", fname, $(8), val, new_var) }' \ |while read fname var val new_var; do sed -r -i -e "s/${var}[[:space:]]*=[[:space:]]*${val}/${new_var} = YES/" "${fname}" done $ git diff -I'CPE_ID_(VENDOR|VALID)' [empty] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
38 lines
1.2 KiB
Makefile
38 lines
1.2 KiB
Makefile
################################################################################
|
|
#
|
|
# logrotate
|
|
#
|
|
################################################################################
|
|
|
|
LOGROTATE_VERSION = 3.21.0
|
|
LOGROTATE_SOURCE = logrotate-$(LOGROTATE_VERSION).tar.xz
|
|
LOGROTATE_SITE = https://github.com/logrotate/logrotate/releases/download/$(LOGROTATE_VERSION)
|
|
LOGROTATE_LICENSE = GPL-2.0+
|
|
LOGROTATE_LICENSE_FILES = COPYING
|
|
LOGROTATE_CPE_ID_VALID = YES
|
|
LOGROTATE_DEPENDENCIES = popt host-pkgconf
|
|
LOGROTATE_SELINUX_MODULES = logrotate
|
|
LOGROTATE_CONF_ENV = LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs popt`"
|
|
|
|
ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
|
|
LOGROTATE_CONF_OPTS += --with-selinux
|
|
LOGROTATE_DEPENDENCIES += libselinux
|
|
else
|
|
LOGROTATE_CONF_OPTS += --without-selinux
|
|
endif
|
|
|
|
ifeq ($(BR2_PACKAGE_ACL),y)
|
|
LOGROTATE_DEPENDENCIES += acl
|
|
LOGROTATE_CONF_OPTS += --with-acl
|
|
else
|
|
LOGROTATE_CONF_OPTS += --without-acl
|
|
endif
|
|
|
|
define LOGROTATE_INSTALL_TARGET_CONF
|
|
$(INSTALL) -m 0644 package/logrotate/logrotate.conf $(TARGET_DIR)/etc/logrotate.conf
|
|
$(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/logrotate.d
|
|
endef
|
|
LOGROTATE_POST_INSTALL_TARGET_HOOKS += LOGROTATE_INSTALL_TARGET_CONF
|
|
|
|
$(eval $(autotools-package))
|