c6ef948f29
The current tagged version is more than 6 years old, and no new tags have been made upstream, so let's update to the latest git version. The current version contains many fixes and improvements and supports several new types of USB gadgets. The patch was a backport from upstream, so it can be dropped. Also, upstream has changed from https://github.com/libusbgx/libusbgx to https://github.com/linux-usb-gadgets/libusbgx: the former is a redirect to the latter. Signed-off-by: Alexander Shiyan <eagle.alexander923@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
16 lines
556 B
Makefile
16 lines
556 B
Makefile
################################################################################
|
|
#
|
|
# libusbgx
|
|
#
|
|
################################################################################
|
|
|
|
LIBUSBGX_VERSION = a5bfa81017a9b2064bc449cf74f5f9d106445f62
|
|
LIBUSBGX_SITE = $(call github,linux-usb-gadgets,libusbgx,$(LIBUSBGX_VERSION))
|
|
LIBUSBGX_LICENSE = GPL-2.0+ (examples), LGPL-2.1+ (library)
|
|
LIBUSBGX_LICENSE_FILES = COPYING COPYING.LGPL
|
|
LIBUSBGX_DEPENDENCIES = host-pkgconf libconfig
|
|
LIBUSBGX_AUTORECONF = YES
|
|
LIBUSBGX_INSTALL_STAGING = YES
|
|
|
|
$(eval $(autotools-package))
|