c19cca0452
Now that we document _CPE_ID_VALID, and that it shall be used instead of setting a default value to one of the other _CPE_ID_* variables, change all of the existing packages to use it, to avoid any error when we later extend check-package to validate the sanity ofthe _CPE_ID_* variables. Mechanical change done within the reference container, running the new check in check-package, to report the CPE_ID errors: $ make check-package 2>/dev/null \ |awk '{ split($(1), a, ":"); fname = a[1] split($(2), a, "'\''"); val = a[2] new_var = $(8); gsub("_CPE_ID_.*", "_CPE_ID_VALID", new_var) printf("%s %s %s %s\n", fname, $(8), val, new_var) }' \ |while read fname var val new_var; do sed -r -i -e "s/${var}[[:space:]]*=[[:space:]]*${val}/${new_var} = YES/" "${fname}" done $ git diff -I'CPE_ID_(VENDOR|VALID)' [empty] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
44 lines
1.4 KiB
Makefile
44 lines
1.4 KiB
Makefile
################################################################################
|
|
#
|
|
# libnids
|
|
#
|
|
################################################################################
|
|
|
|
LIBNIDS_VERSION = 1.26
|
|
LIBNIDS_SITE = $(call github,MITRECND,libnids,$(LIBNIDS_VERSION))
|
|
LIBNIDS_LICENSE = GPL-2.0
|
|
LIBNIDS_LICENSE_FILES = COPYING
|
|
LIBNIDS_CPE_ID_VALID = YES
|
|
LIBNIDS_INSTALL_STAGING = YES
|
|
LIBNIDS_DEPENDENCIES = host-pkgconf libpcap
|
|
LIBNIDS_AUTORECONF = YES
|
|
|
|
# disable libnet if not available
|
|
# Tests in configure.in expect --with-libnet=$build_dir
|
|
# not an installation patch like in our context.
|
|
# We use with-libnet=yes to skip the unusual paths tests.
|
|
# But 'LNETLIB' gets left out, so we need to define it ourselves.
|
|
ifeq ($(BR2_PACKAGE_LIBNET),y)
|
|
LIBNIDS_DEPENDENCIES += libnet
|
|
LIBNIDS_CONF_OPTS += --enable-libnet --with-libnet=yes LNETLIB=-lnet
|
|
else
|
|
LIBNIDS_CONF_OPTS += --disable-libnet
|
|
endif
|
|
|
|
# disable libglib2 if not available
|
|
# The test in configure.in is flawed: passing --enable-libglib would also
|
|
# disable it. Only when neither is passed will the autodetection test be
|
|
# executed.
|
|
ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
|
|
LIBNIDS_DEPENDENCIES += libglib2
|
|
else
|
|
LIBNIDS_CONF_OPTS += --disable-libglib
|
|
endif
|
|
|
|
# hand-written Makefile.in, not using automake, needs a custom
|
|
# variable for the installation path.
|
|
LIBNIDS_INSTALL_STAGING_OPTS = install_prefix=$(STAGING_DIR) install
|
|
LIBNIDS_INSTALL_TARGET_OPTS = install_prefix=$(TARGET_DIR) install
|
|
|
|
$(eval $(autotools-package))
|