c19cca0452
Now that we document _CPE_ID_VALID, and that it shall be used instead of setting a default value to one of the other _CPE_ID_* variables, change all of the existing packages to use it, to avoid any error when we later extend check-package to validate the sanity ofthe _CPE_ID_* variables. Mechanical change done within the reference container, running the new check in check-package, to report the CPE_ID errors: $ make check-package 2>/dev/null \ |awk '{ split($(1), a, ":"); fname = a[1] split($(2), a, "'\''"); val = a[2] new_var = $(8); gsub("_CPE_ID_.*", "_CPE_ID_VALID", new_var) printf("%s %s %s %s\n", fname, $(8), val, new_var) }' \ |while read fname var val new_var; do sed -r -i -e "s/${var}[[:space:]]*=[[:space:]]*${val}/${new_var} = YES/" "${fname}" done $ git diff -I'CPE_ID_(VENDOR|VALID)' [empty] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
42 lines
1.1 KiB
Makefile
42 lines
1.1 KiB
Makefile
################################################################################
|
|
#
|
|
# libaio
|
|
#
|
|
################################################################################
|
|
|
|
LIBAIO_VERSION = 0.3.113
|
|
LIBAIO_SITE = https://releases.pagure.org/libaio
|
|
LIBAIO_INSTALL_STAGING = YES
|
|
LIBAIO_LICENSE = LGPL-2.1+
|
|
LIBAIO_LICENSE_FILES = COPYING
|
|
LIBAIO_CPE_ID_VALID = YES
|
|
|
|
LIBAIO_CONFIGURE_OPTS = $(TARGET_CONFIGURE_OPTS)
|
|
|
|
ifeq ($(BR2_STATIC_LIBS),y)
|
|
LIBAIO_CONFIGURE_OPTS += ENABLE_SHARED=0
|
|
endif
|
|
|
|
define LIBAIO_BUILD_CMDS
|
|
$(LIBAIO_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
|
|
endef
|
|
|
|
define LIBAIO_INSTALL_STAGING_CMDS
|
|
$(LIBAIO_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) install
|
|
endef
|
|
|
|
define LIBAIO_INSTALL_TARGET_CMDS
|
|
$(LIBAIO_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
|
|
endef
|
|
|
|
define HOST_LIBAIO_BUILD_CMDS
|
|
$(HOST_CONFIGURE_OPTS) $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
|
|
endef
|
|
|
|
define HOST_LIBAIO_INSTALL_CMDS
|
|
$(HOST_CONFIGURE_OPTS) $(HOST_MAKE_ENV) $(MAKE) -C $(@D) prefix=$(HOST_DIR) install
|
|
endef
|
|
|
|
$(eval $(generic-package))
|
|
$(eval $(host-generic-package))
|