kumquat-buildroot/package/flashbench/flashbench.mk
Markus Mayer 6626bf7c5f package: replace git:// URLs with https:// URLs where possible
Replace the remaining git:// URLs with their https:// equivalents as
this is more secure and also more palatable to corporate firewalls.

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
[yann.morin.1998@free.fr: convert dahdi-linux too]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2022-04-02 19:21:57 +02:00

25 lines
756 B
Makefile

################################################################################
#
# flashbench
#
################################################################################
FLASHBENCH_VERSION = 2e30b1968a66147412f21002ea844122a0d5e2f0
FLASHBENCH_SITE = https://git.linaro.org/people/arnd/flashbench.git
FLASHBENCH_SITE_METHOD = git
FLASHBENCH_LICENSE = GPL-2.0
FLASHBENCH_LICENSE_FILES = COPYING
define FLASHBENCH_BUILD_CMDS
$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS) -lrt"
endef
define FLASHBENCH_INSTALL_TARGET_CMDS
$(INSTALL) -m 755 -D $(@D)/flashbench $(TARGET_DIR)/usr/bin/flashbench
$(INSTALL) -m 755 -D $(@D)/erase $(TARGET_DIR)/usr/bin/erase
endef
$(eval $(generic-package))