a1d5e366b5
The server was decommisioned in 2017 and is unlikely to ever come back, so drop the reference: https://www.doomworld.com/forum/topic/96999-rip-ftpidsoftwarecom/ Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
24 lines
741 B
Makefile
24 lines
741 B
Makefile
################################################################################
|
|
#
|
|
# doom-wad
|
|
#
|
|
################################################################################
|
|
|
|
DOOM_WAD_VERSION = 1.9
|
|
DOOM_WAD_SOURCE = doom$(subst .,,$(DOOM_WAD_VERSION))s.zip
|
|
# Official server currently unavailable
|
|
DOOM_WAD_SITE = http://www.jbserver.com/downloads/games/doom/misc/shareware
|
|
|
|
define DOOM_WAD_EXTRACT_CMDS
|
|
$(UNZIP) -p $(DOOM_WAD_DL_DIR)/$($(PKG)_SOURCE) 'DOOMS_19.[12]' > \
|
|
$(@D)/doom-$(DOOM_WAD_VERSION).zip
|
|
$(UNZIP) -d $(@D) $(@D)/doom-$(DOOM_WAD_VERSION).zip DOOM1.WAD
|
|
endef
|
|
|
|
define DOOM_WAD_INSTALL_TARGET_CMDS
|
|
$(INSTALL) -m 0644 -D $(@D)/DOOM1.WAD \
|
|
$(TARGET_DIR)/usr/share/games/doom/doom1.wad
|
|
endef
|
|
|
|
$(eval $(generic-package))
|