99abd6e406
When glibc was bumped to version 2.39 in commit
b5680f53d6
it removed the deprecated
libcrypt support.
As glibc's libcrypt was providing apg's libcrypt dependency this broke
the apg build using glibc version 2.39.
To fix this select the libxcrypt dependency to apg when using a glibc
toolchain and add the dependency if selected.
Fixes:
http://autobuild.buildroot.net/results/3df84ae300bb648492cffc21e4481fc5abf02aeb/
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
25 lines
593 B
Makefile
25 lines
593 B
Makefile
################################################################################
|
|
#
|
|
# apg
|
|
#
|
|
################################################################################
|
|
|
|
APG_VERSION = 2.3.0b
|
|
APG_SITE = $(call github,wilx,apg,v$(APG_VERSION))
|
|
APG_LICENSE = BSD-3-Clause
|
|
APG_LICENSE_FILES = COPYING
|
|
|
|
ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
|
|
APG_DEPENDENCIES += libxcrypt
|
|
endif
|
|
|
|
define APG_BUILD_CMDS
|
|
$(MAKE) $(TARGET_CONFIGURE_OPTS) FLAGS="$(TARGET_CFLAGS)" -C $(@D)
|
|
endef
|
|
|
|
define APG_INSTALL_TARGET_CMDS
|
|
$(INSTALL) -D -m 0755 $(@D)/apg $(TARGET_DIR)/usr/bin/apg
|
|
endef
|
|
|
|
$(eval $(generic-package))
|