kumquat-buildroot/package/alsa-plugins/alsa-plugins.mk
Charles Hardin 3223a34ee5 package/alsa-plugins: fix dependencies for the alsa plugin package
The alsa-utils will remove and create the /usr/share/alsa dir
as a whole and since the alsa plugins needs to add config into
this same directory it should come after those install steps.

Also, the bluez alsa needs the plugins installed to find them
during the configuration phases - so, interlock the plugins
when configured.

Signed-off-by: Charles Hardin <ckhardin@gmail.com>
Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
2023-06-25 21:54:38 +02:00

37 lines
1.0 KiB
Makefile

################################################################################
#
# alsa-plugins
#
################################################################################
ALSA_PLUGINS_VERSION = 1.2.7.1
ALSA_PLUGINS_SOURCE = alsa-plugins-$(ALSA_PLUGINS_VERSION).tar.bz2
ALSA_PLUGINS_SITE = https://www.alsa-project.org/files/pub/plugins
ALSA_PLUGINS_LICENSE = LGPL-2.1+
ALSA_PLUGINS_LICENSE_FILES = COPYING
ALSA_PLUGINS_DEPENDENCIES = host-pkgconf alsa-lib
ALSA_PLUGINS_CONF_OPTS = \
--disable-jack \
--disable-usbstream \
--disable-pulseaudio \
--disable-libav \
--disable-maemo-plugin \
--disable-maemo-resource-manager \
--with-speex=no
ifeq ($(BR2_PACKAGE_ALSA_UTILS),y)
ALSA_PLUGINS_DEPENDENCIES += alsa-utils
endif
ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
ALSA_PLUGINS_CONF_OPTS += --enable-samplerate
ALSA_PLUGINS_DEPENDENCIES += libsamplerate
ALSA_PLUGINS_LICENSE += , GPL-2.0+ (samplerate plugin)
ALSA_PLUGINS_LICENSE_FILES += COPYING.GPL
else
ALSA_PLUGINS_CONF_OPTS += --disable-samplerate
endif
$(eval $(autotools-package))