package/madplay: fix build when NLS is enabled

MKINSTALLDIRS is not automatically called by autotools when
autoreconfigured.
This leads to the following error during install:

`/bin/sh @MKINSTALLDIRS@ /home/dawncrow/buildroot-test/scripts/instance-0/output/target/usr/share
/bin/sh: 0: Can't open @MKINSTALLDIRS@`

because @MKINSTALLDIRS@ doesn't get substituted during autoreconf.

This particular command only gets invoked when NLS is enabled.

Add patch that explicitly calls AM_MKINSTALLDIRS macro to substitute
every @MKINSTALLDIRS@ occurence in *.in Makefile.

Patch is not sent upstream since upstream is dead.

Fixes:
http://autobuild.buildroot.net/results/744/7447c03426556f787f20f7ab2d36f0cacc4af1bd/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
(cherry picked from commit 00b733a39b)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Giulio Benetti 2019-04-16 12:21:25 +02:00 committed by Peter Korsgaard
parent 88eff22a9e
commit ffb839ce3e

View File

@ -0,0 +1,23 @@
configure.ac: call AM_MKINSTALLDIRS to substitute @MKINSTALLDIRS@
MKINSTALLDIRS is obsolete and doesn't get automatically called.
Force call AM_MKINSTALLDIRS() macro to substitute every @MKINSTALLDIRS@
occurence in *.in files.
Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
diff -urpN madplay-0.15.2b.orig/configure.ac madplay-0.15.2b/configure.ac
--- madplay-0.15.2b.orig/configure.ac 2019-04-16 12:06:03.781018755 +0200
+++ madplay-0.15.2b/configure.ac 2019-04-16 12:07:48.399162610 +0200
@@ -146,6 +146,10 @@ ALL_LINGUAS="en es fr hr no"
AM_GNU_GETTEXT([use-libtool])
AM_GNU_GETTEXT_VERSION(0.14.1)
+dnl Substitute MKINSTALLDIRS
+
+AM_MKINSTALLDIRS()
+
dnl Checks for header files.
AC_HEADER_STDC