package/cloop: bump to version 3.14.1.2

- Remove patch, it is not needed anymore as CFLAGS/LDFLAGS are now
  correctly passed to extract_compressed_fs. CFLAGS/LDFLAGS are not
  passed to cloop_suspend but it isn't built. Moreover original CFLAGS
  are lost but this is acceptable)
- Switch site to http://snapshot.debian.org/archive/debian as
  http://debian-knoppix.alioth.debian.org/packages/sources/cloop is not
  available anymore
- Add hash for license files

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2019-08-01 14:21:09 +02:00 committed by Peter Korsgaard
parent edf97df877
commit ff68ca92cb
3 changed files with 9 additions and 35 deletions

View File

@ -1,30 +0,0 @@
Take into account the CFLAGS/LDFLAGS passed in the environment.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: host-cloop-2.634-1/Makefile
===================================================================
--- host-cloop-2.634-1.orig/Makefile 2010-12-16 09:17:52.826555645 +0100
+++ host-cloop-2.634-1/Makefile 2010-12-16 09:18:57.208713338 +0100
@@ -15,7 +15,7 @@
endif
ifdef APPSONLY
-CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
+CLOOP_CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
endif
KERNOBJ:=compressed_loop.o
@@ -53,10 +53,10 @@
( cd advancecomp-1.15 ; ./configure && $(MAKE) advfs )
extract_compressed_fs: extract_compressed_fs.c
- $(CC) -Wall -O2 -s -o $@ $< -lz
+ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -Wall -O2 -s -o $@ $< -lz
cloop_suspend: cloop_suspend.o
- $(CC) -o $@ $<
+ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -o $@ $<
clean:
rm -rf create_compressed_fs extract_compressed_fs zoom *.o *.ko Module.symvers .cloop* .compressed_loop.* .tmp*

View File

@ -1,2 +1,6 @@
# From http://debian-knoppix.alioth.debian.org/packages/sources/cloop/cloop_2.634-1.dsc
sha256 d6d03e2368e19f9c6c3a313e9c34cf0620d129ce26132a8805580d953769dbbd cloop_2.634-1.tar.gz
# From http://snapshot.debian.org/archive/debian/20150503T155713Z/pool/main/c/cloop/cloop_3.14.1.2.dsc
sha256 ac344225b3a5c4ddbb0d4b20cd4874798b51427b707b53e2ee9fbdada7497c95 cloop_3.14.1.2.tar.xz
# Hash for license files
sha256 91df39d1816bfb17a4dda2d3d2c83b1f6f2d38d53e53e41e8f97ad5ac46a0cad advancecomp-1.15/COPYING
sha256 1b1f89e94e131e259b9e334565c5c3500d4b8aa755b75c3f145ddcdff3b89124 README

View File

@ -4,9 +4,9 @@
#
################################################################################
CLOOP_VERSION = 2.634-1
CLOOP_SOURCE = cloop_$(CLOOP_VERSION).tar.gz
CLOOP_SITE = http://debian-knoppix.alioth.debian.org/packages/sources/cloop
CLOOP_VERSION = 3.14.1.2
CLOOP_SOURCE = cloop_$(CLOOP_VERSION).tar.xz
CLOOP_SITE = http://snapshot.debian.org/archive/debian/20150503T155713Z/pool/main/c/cloop
CLOOP_LICENSE = GPL-2.0 (module), GPL-2.0+ (advancecomp)
CLOOP_LICENSE_FILES = README advancecomp-1.15/COPYING