package/mcelog: bump to version 184
Include a patch to introduce the `install-nodoc` make target to avoid a dependency on host-python3 for manpage generation. Upstream: https://github.com/andikleen/mcelog/pull/109 Signed-off-by: Vincent Fazio <vfazio@xes-inc.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
acb02354a1
commit
ff59cbf536
65
package/mcelog/0001-Makefile-add-install-nodoc-target.patch
Normal file
65
package/mcelog/0001-Makefile-add-install-nodoc-target.patch
Normal file
@ -0,0 +1,65 @@
|
||||
From c224ad8bafe859d640dfaf67d396c38c73880409 Mon Sep 17 00:00:00 2001
|
||||
From: Vincent Fazio <vfazio@xes-inc.com>
|
||||
Date: Wed, 27 Jul 2022 07:18:37 -0500
|
||||
Subject: [PATCH] Makefile: add install-nodoc target
|
||||
|
||||
This target is useful for "essentials only" installs for embedded
|
||||
environments with the added benefit of not requiring a python
|
||||
interpreter for installing the package.
|
||||
|
||||
Suggested-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>
|
||||
---
|
||||
Makefile | 19 +++++++++++--------
|
||||
1 file changed, 11 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 339b8dd..50a322b 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -28,7 +28,7 @@ TRIGGERS=cache-error-trigger dimm-error-trigger page-error-trigger \
|
||||
|
||||
all: mcelog
|
||||
|
||||
-.PHONY: install clean depend FORCE
|
||||
+.PHONY: install install-nodoc clean depend FORCE
|
||||
|
||||
OBJ := p4.o k8.o mcelog.o dmi.o tsc.o core2.o bitfield.o intel.o \
|
||||
nehalem.o dunnington.o tulsa.o config.o memutil.o msg.o \
|
||||
@@ -50,16 +50,11 @@ SRC := $(OBJ:.o=.c)
|
||||
mcelog: ${OBJ} version.o
|
||||
|
||||
# dbquery intentionally not installed by default
|
||||
-install: mcelog mcelog.conf mcelog.conf.5 mcelog.triggers.5
|
||||
- mkdir -p $(DESTDIR)${etcprefix}/etc/mcelog $(DESTDIR)${prefix}/sbin $(DESTDIR)$(MANDIR)/man5 $(DESTDIR)$(MANDIR)/man8
|
||||
- install -m 755 -p mcelog $(DESTDIR)${prefix}/sbin/mcelog
|
||||
+install: install-nodoc mcelog.conf.5 mcelog.triggers.5
|
||||
+ mkdir -p $(DESTDIR)$(MANDIR)/man5 $(DESTDIR)$(MANDIR)/man8
|
||||
install -m 644 -p mcelog.8 $(DESTDIR)$(MANDIR)/man8
|
||||
install -m 644 -p mcelog.conf.5 $(DESTDIR)$(MANDIR)/man5
|
||||
install -m 644 -p mcelog.triggers.5 $(DESTDIR)$(MANDIR)/man5
|
||||
- install -m 644 -p -b mcelog.conf $(DESTDIR)${etcprefix}/etc/mcelog/mcelog.conf
|
||||
- for i in ${TRIGGERS} ; do \
|
||||
- install -m 755 -p -b triggers/$$i $(DESTDIR)${etcprefix}/etc/mcelog ; \
|
||||
- done
|
||||
ifdef DOCDIR
|
||||
install -d 755 $(DESTDIR)${DOCDIR}
|
||||
install -m 644 -p ${DOC} $(DESTDIR)${DOCDIR}
|
||||
@@ -68,6 +63,14 @@ else
|
||||
echo "Consider defining DOCDIR to install additional documentation"
|
||||
endif
|
||||
|
||||
+install-nodoc: mcelog mcelog.conf
|
||||
+ mkdir -p $(DESTDIR)${etcprefix}/etc/mcelog $(DESTDIR)${prefix}/sbin
|
||||
+ install -m 755 -p mcelog $(DESTDIR)${prefix}/sbin/mcelog
|
||||
+ install -m 644 -p -b mcelog.conf $(DESTDIR)${etcprefix}/etc/mcelog/mcelog.conf
|
||||
+ for i in ${TRIGGERS} ; do \
|
||||
+ install -m 755 -p -b triggers/$$i $(DESTDIR)${etcprefix}/etc/mcelog ; \
|
||||
+ done
|
||||
+
|
||||
mcelog.conf.5: mcelog.conf config-intro.man
|
||||
./genconfig.py mcelog.conf config-intro.man > mcelog.conf.5
|
||||
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 e9c82b565da06673c2630f9e6bc668634ad7d2c7f13c70db1900cce110ae62dc mcelog-180.tar.gz
|
||||
sha256 067d52006f0aa42045acc6d9c04d590362448bacd8ef415d42729e6f35825028 mcelog-184.tar.gz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
MCELOG_VERSION = 180
|
||||
MCELOG_VERSION = 184
|
||||
MCELOG_SITE = $(call github,andikleen,mcelog,v$(MCELOG_VERSION))
|
||||
MCELOG_LICENSE = GPL-2.0
|
||||
MCELOG_LICENSE_FILES = LICENSE
|
||||
@ -15,7 +15,7 @@ define MCELOG_BUILD_CMDS
|
||||
endef
|
||||
|
||||
define MCELOG_INSTALL_TARGET_CMDS
|
||||
$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) DESTDIR=$(TARGET_DIR) install
|
||||
$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) DESTDIR=$(TARGET_DIR) install-nodoc
|
||||
endef
|
||||
|
||||
define MCELOG_INSTALL_INIT_SYSTEMD
|
||||
|
Loading…
Reference in New Issue
Block a user