configs/qemu: Update defconfigs to Linux 4.19.16
Linux version are changed to 4.19.16 (LTS) for all qemu defconfigs,
except for riscv. riscv defconfigs are left unchanged because they have
a custom Linux repository causing more difficulties when upgrading to
4.19 for riscv32. And for the riscv64, it has been updated recently to
Linux 4.20 by another contributor.
Patch for arm-versatile-nommu is changed into a git format
Add cache attributes for xtensa-lx60-nommu config because the commit
7bb516ca54
added a new config variable for memory cache attribute:
CONFIG_MEMMAP_CACHEATTR
All these updated configs have been built successfully.
Signed-off-by: Gerome Burlats <gerome.burlats@smile.fr>
Cc: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
a83e30ad63
commit
fd8a02fd75
board/qemu
configs
qemu_aarch64_virt_defconfigqemu_arm_versatile_defconfigqemu_arm_versatile_nommu_defconfigqemu_arm_vexpress_defconfigqemu_m68k_mcf5208_defconfigqemu_m68k_q800_defconfigqemu_microblazebe_mmu_defconfigqemu_microblazeel_mmu_defconfigqemu_mips32r2_malta_defconfigqemu_mips32r2el_malta_defconfigqemu_mips32r6_malta_defconfigqemu_mips32r6el_malta_defconfigqemu_mips64_malta_defconfigqemu_mips64el_malta_defconfigqemu_mips64r6_malta_defconfigqemu_mips64r6el_malta_defconfigqemu_nios2_10m50_defconfigqemu_or1k_defconfigqemu_ppc64_e5500_defconfigqemu_ppc64_pseries_defconfigqemu_ppc64le_pseries_defconfigqemu_ppc_g3beige_defconfigqemu_ppc_mpc8544ds_defconfigqemu_ppc_virtex_ml507_defconfigqemu_sh4_r2d_defconfigqemu_sh4eb_r2d_defconfigqemu_sparc64_sun4u_defconfigqemu_sparc_ss10_defconfigqemu_x86_64_defconfigqemu_x86_defconfigqemu_xtensa_lx60_defconfigqemu_xtensa_lx60_nommu_defconfig
@ -1,10 +1,30 @@
|
||||
Signed-Off-by: Waldemar Brodkorb <wbx@openadk.org>
|
||||
From LKML.
|
||||
From 4ac4324dcdaf237aa34545b3795acb2e5c42d10e Mon Sep 17 00:00:00 2001
|
||||
From: Waldemar Brodkorb <wbx@openadk.org>
|
||||
Date: Fri, 1 Feb 2019 11:36:20 +0100
|
||||
Subject: [PATCH] arm-versatile-nommu: Linux patch
|
||||
|
||||
diff -Nur linux-4.15.13.orig/arch/arm/Kconfig linux-4.15.13/arch/arm/Kconfig
|
||||
--- linux-4.15.13.orig/arch/arm/Kconfig 2018-03-24 11:02:53.000000000 +0100
|
||||
+++ linux-4.15.13/arch/arm/Kconfig 2018-04-01 03:47:33.415078244 +0100
|
||||
@@ -355,6 +355,17 @@
|
||||
Originally made by Waldemar Brodkorb <wbx@openadk.org> from LKML.
|
||||
|
||||
Signed-Off-by: Waldemar Brodkorb <wbx@openadk.org>
|
||||
[Gerome: reformated as a Git patch]
|
||||
Signed-off-by: Gerome Burlats <gerome.burlats@smile.fr>
|
||||
[Romain: fix Waldemar's authorship in Git patch]
|
||||
Signed-off-by: Romain Naour <romain.naour@smile.fr>
|
||||
---
|
||||
arch/arm/Kconfig | 11 +++++++++++
|
||||
arch/arm/Kconfig.debug | 3 ++-
|
||||
arch/arm/include/asm/mach/map.h | 1 +
|
||||
arch/arm/mach-versatile/Kconfig | 5 +++--
|
||||
arch/arm/mach-versatile/Makefile.boot | 3 +++
|
||||
arch/arm/mach-versatile/versatile_dt.c | 4 ++++
|
||||
6 files changed, 24 insertions(+), 3 deletions(-)
|
||||
create mode 100644 arch/arm/mach-versatile/Makefile.boot
|
||||
|
||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||
index e8cd55a5b04c..fc2dbff70394 100644
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -353,6 +353,17 @@ config ARM_SINGLE_ARMV7M
|
||||
select SPARSE_IRQ
|
||||
select USE_OF
|
||||
|
||||
@ -22,10 +42,11 @@ diff -Nur linux-4.15.13.orig/arch/arm/Kconfig linux-4.15.13/arch/arm/Kconfig
|
||||
config ARCH_EBSA110
|
||||
bool "EBSA-110"
|
||||
select ARCH_USES_GETTIMEOFFSET
|
||||
diff -Nur linux-4.15.13.orig/arch/arm/Kconfig.debug linux-4.15.13/arch/arm/Kconfig.debug
|
||||
--- linux-4.15.13.orig/arch/arm/Kconfig.debug 2018-03-24 11:02:53.000000000 +0100
|
||||
+++ linux-4.15.13/arch/arm/Kconfig.debug 2018-04-01 03:47:33.416078232 +0100
|
||||
@@ -1795,7 +1795,8 @@
|
||||
diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug
|
||||
index f6fcb8a79889..92fc637d3db8 100644
|
||||
--- a/arch/arm/Kconfig.debug
|
||||
+++ b/arch/arm/Kconfig.debug
|
||||
@@ -1843,7 +1843,8 @@ config DEBUG_UNCOMPRESS
|
||||
config UNCOMPRESS_INCLUDE
|
||||
string
|
||||
default "debug/uncompress.h" if ARCH_MULTIPLATFORM || ARCH_MSM || \
|
||||
@ -35,10 +56,11 @@ diff -Nur linux-4.15.13.orig/arch/arm/Kconfig.debug linux-4.15.13/arch/arm/Kconf
|
||||
default "mach/uncompress.h"
|
||||
|
||||
config EARLY_PRINTK
|
||||
diff -Nur linux-4.15.13.orig/arch/arm/include/asm/mach/map.h linux-4.15.13/arch/arm/include/asm/mach/map.h
|
||||
--- linux-4.15.13.orig/arch/arm/include/asm/mach/map.h 2018-03-24 11:02:53.000000000 +0100
|
||||
+++ linux-4.15.13/arch/arm/include/asm/mach/map.h 2018-04-01 03:47:17.587276119 +0100
|
||||
@@ -62,6 +62,7 @@
|
||||
diff --git a/arch/arm/include/asm/mach/map.h b/arch/arm/include/asm/mach/map.h
|
||||
index 9b7c328fb207..b1fe9c8b5c3e 100644
|
||||
--- a/arch/arm/include/asm/mach/map.h
|
||||
+++ b/arch/arm/include/asm/mach/map.h
|
||||
@@ -62,6 +62,7 @@ extern int ioremap_page(unsigned long virt, unsigned long phys,
|
||||
#else
|
||||
#define iotable_init(map,num) do { } while (0)
|
||||
#define vm_reserve_area_early(a,s,c) do { } while (0)
|
||||
@ -46,9 +68,10 @@ diff -Nur linux-4.15.13.orig/arch/arm/include/asm/mach/map.h linux-4.15.13/arch/
|
||||
#endif
|
||||
|
||||
#endif
|
||||
diff -Nur linux-4.15.13.orig/arch/arm/mach-versatile/Kconfig linux-4.15.13/arch/arm/mach-versatile/Kconfig
|
||||
--- linux-4.15.13.orig/arch/arm/mach-versatile/Kconfig 2018-03-24 11:02:53.000000000 +0100
|
||||
+++ linux-4.15.13/arch/arm/mach-versatile/Kconfig 2018-04-01 03:47:33.417078219 +0100
|
||||
diff --git a/arch/arm/mach-versatile/Kconfig b/arch/arm/mach-versatile/Kconfig
|
||||
index f5c275434d6c..06ad999d5978 100644
|
||||
--- a/arch/arm/mach-versatile/Kconfig
|
||||
+++ b/arch/arm/mach-versatile/Kconfig
|
||||
@@ -1,7 +1,8 @@
|
||||
# SPDX-License-Identifier: GPL-2.0
|
||||
config ARCH_VERSATILE
|
||||
@ -60,16 +83,19 @@ diff -Nur linux-4.15.13.orig/arch/arm/mach-versatile/Kconfig linux-4.15.13/arch/
|
||||
select ARM_AMBA
|
||||
select ARM_TIMER_SP804
|
||||
select ARM_VIC
|
||||
diff -Nur linux-4.15.13.orig/arch/arm/mach-versatile/Makefile.boot linux-4.15.13/arch/arm/mach-versatile/Makefile.boot
|
||||
--- linux-4.15.13.orig/arch/arm/mach-versatile/Makefile.boot 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ linux-4.15.13/arch/arm/mach-versatile/Makefile.boot 2018-04-01 03:47:25.644175394 +0100
|
||||
diff --git a/arch/arm/mach-versatile/Makefile.boot b/arch/arm/mach-versatile/Makefile.boot
|
||||
new file mode 100644
|
||||
index 000000000000..eacfc3f5c33e
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/mach-versatile/Makefile.boot
|
||||
@@ -0,0 +1,3 @@
|
||||
+# Empty file waiting for deletion once Makefile.boot isn't needed any more.
|
||||
+# Patch waits for application at
|
||||
+# http://www.arm.linux.org.uk/developer/patches/viewpatch.php?id=7889/1 .
|
||||
diff -Nur linux-4.15.13.orig/arch/arm/mach-versatile/versatile_dt.c linux-4.15.13/arch/arm/mach-versatile/versatile_dt.c
|
||||
--- linux-4.15.13.orig/arch/arm/mach-versatile/versatile_dt.c 2018-03-24 11:02:53.000000000 +0100
|
||||
+++ linux-4.15.13/arch/arm/mach-versatile/versatile_dt.c 2018-04-01 03:47:10.913359555 +0100
|
||||
diff --git a/arch/arm/mach-versatile/versatile_dt.c b/arch/arm/mach-versatile/versatile_dt.c
|
||||
index 3c8d39c12909..8cfa05a37295 100644
|
||||
--- a/arch/arm/mach-versatile/versatile_dt.c
|
||||
+++ b/arch/arm/mach-versatile/versatile_dt.c
|
||||
@@ -37,7 +37,11 @@
|
||||
#include <asm/mach/map.h>
|
||||
|
||||
@ -82,3 +108,6 @@ diff -Nur linux-4.15.13.orig/arch/arm/mach-versatile/versatile_dt.c linux-4.15.1
|
||||
#define __io_address(n) ((void __iomem __force *)IO_ADDRESS(n))
|
||||
|
||||
/*
|
||||
--
|
||||
2.14.5
|
||||
|
||||
|
@ -6,6 +6,7 @@ CONFIG_XTENSA_VARIANT_CUSTOM_NAME="dc233c"
|
||||
# CONFIG_XTENSA_VARIANT_MMU is not set
|
||||
CONFIG_XTENSA_UNALIGNED_USER=y
|
||||
CONFIG_PREEMPT=y
|
||||
CONFIG_MEMMAP_CACHEATTR=0x2cccccc7
|
||||
CONFIG_KERNEL_LOAD_ADDRESS=0x00003000
|
||||
# CONFIG_PCI is not set
|
||||
CONFIG_XTENSA_PLATFORM_XTFPGA=y
|
||||
|
@ -11,13 +11,13 @@ BR2_TARGET_ROOTFS_EXT2=y
|
||||
BR2_TARGET_ROOTFS_EXT2_4=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/aarch64-virt/linux.config"
|
||||
BR2_LINUX_KERNEL_NEEDS_HOST_OPENSSL=y
|
||||
|
@ -10,13 +10,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttyAMA0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/arm-versatile/linux.config"
|
||||
BR2_LINUX_KERNEL_DTS_SUPPORT=y
|
||||
|
@ -21,13 +21,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttyAMA0"
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/arm-versatile/linux-nommu.config"
|
||||
BR2_LINUX_KERNEL_DTS_SUPPORT=y
|
||||
|
@ -13,13 +13,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttyAMA0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_DEFCONFIG="vexpress"
|
||||
BR2_LINUX_KERNEL_DTS_SUPPORT=y
|
||||
BR2_LINUX_KERNEL_INTREE_DTS_NAME="vexpress-v2p-ca9"
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/m68k-mcf5208/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/m68k-q800/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -10,13 +10,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttyUL0"
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/microblazebe-mmu/linux.config"
|
||||
BR2_LINUX_KERNEL_LINUX_BIN=y
|
||||
|
@ -10,13 +10,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttyUL0"
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/microblazeel-mmu/linux.config"
|
||||
BR2_LINUX_KERNEL_LINUX_BIN=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips32r2-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips32r2el-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips32r6-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips32r6el-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips64-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips64el-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -10,13 +10,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips64r6-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -10,13 +10,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/mips64r6el-malta/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -1,10 +1,10 @@
|
||||
BR2_nios2=y
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_DEFCONFIG="10m50"
|
||||
BR2_LINUX_KERNEL_CONFIG_FRAGMENT_FILES="board/qemu/nios2-10m50/linux.fragment"
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
@ -5,12 +5,12 @@ BR2_or1k=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4,16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4,19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/or1k/linux.config"
|
||||
|
@ -6,12 +6,12 @@ BR2_powerpc_e5500=y
|
||||
BR2_TARGET_GENERIC_GETTY_PORT="ttyS0"
|
||||
|
||||
# Linux headers same as the kernel
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_DEFCONFIG="corenet64_smp"
|
||||
BR2_LINUX_KERNEL_CONFIG_FRAGMENT_FILES="board/qemu/ppc64-e5500/linux.fragment"
|
||||
BR2_LINUX_KERNEL_NEEDS_HOST_OPENSSL=y
|
||||
|
@ -10,12 +10,12 @@ BR2_TARGET_GENERIC_GETTY_PORT="hvc0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_DEFCONFIG="pseries"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -10,12 +10,12 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_DEFCONFIG="pseries_le"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/ppc-g3beige/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -9,13 +9,13 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/ppc-mpc8544ds/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -6,8 +6,8 @@ BR2_powerpc_440=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Use soft float
|
||||
BR2_SOFT_FLOAT=y
|
||||
@ -15,7 +15,7 @@ BR2_SOFT_FLOAT=y
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/ppc-virtex-ml507/linux.config"
|
||||
BR2_LINUX_KERNEL_VMLINUX=y
|
||||
|
@ -11,13 +11,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttySC1"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Linux kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/sh4-r2d/linux.config"
|
||||
BR2_LINUX_KERNEL_ZIMAGE=y
|
||||
|
@ -10,13 +10,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttySC1"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Linux kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/sh4eb-r2d/linux.config"
|
||||
BR2_LINUX_KERNEL_ZIMAGE=y
|
||||
|
@ -9,12 +9,12 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Linux kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/sparc64-sun4u/linux.config"
|
||||
|
@ -9,12 +9,12 @@ BR2_SYSTEM_DHCP="eth0"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Linux kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/sparc-ss10/linux.config"
|
||||
|
@ -9,12 +9,12 @@ BR2_TARGET_GENERIC_GETTY_PORT="tty1"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/x86_64/linux.config"
|
||||
|
@ -10,12 +10,12 @@ BR2_TARGET_GENERIC_GETTY_PORT="tty1"
|
||||
BR2_TARGET_ROOTFS_EXT2=y
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/x86/linux.config"
|
||||
|
@ -11,13 +11,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttyS0"
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/xtensa-lx60/linux.config"
|
||||
BR2_LINUX_KERNEL_IMAGE_TARGET_CUSTOM=y
|
||||
|
@ -15,13 +15,13 @@ BR2_TARGET_GENERIC_GETTY_PORT="ttyS0"
|
||||
# BR2_TARGET_ROOTFS_TAR is not set
|
||||
BR2_TARGET_ROOTFS_INITRAMFS=y
|
||||
|
||||
# Linux headers same as kernel, a 4.16 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_16=y
|
||||
# Linux headers same as kernel, a 4.19 series
|
||||
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_19=y
|
||||
|
||||
# Kernel
|
||||
BR2_LINUX_KERNEL=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.16.7"
|
||||
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.19.16"
|
||||
BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
|
||||
BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/xtensa-lx60/linux-nommu.config"
|
||||
BR2_LINUX_KERNEL_IMAGE_TARGET_CUSTOM=y
|
||||
|
Loading…
Reference in New Issue
Block a user