diff --git a/CHANGES b/CHANGES
index 3858296f89..687561eeef 100644
--- a/CHANGES
+++ b/CHANGES
@@ -11,10 +11,10 @@
 	libcgicc, libdaemon, libdrm, libevent, libgail, libglib2,
 	libgpg-error, libmicrohttpd, librsvg, libsoup, libxcp,
 	makedevs, matchbox-fakekey, matchbox-startup-monitor, mdadm,
-	metacity, mpd, nasm, nfs-utils, olsr, popt, pthread-stubs,
-	quagga, rpm, samba, sdl, sdl_gfx, sdl_image, sdl_mixer,
-	sdl_sound, sdl_ttf, squashfs, taglib, tcpreplay, tiff,
-	wpa_supplicant, xcb-util,
+	metacity, mpd, nasm, nfs-utils, olsr, openssl, popt,
+	pthread-stubs, quagga, rpm, samba, sdl, sdl_gfx, sdl_image,
+	sdl_mixer, sdl_sound, sdl_ttf, squashfs, taglib, tcpreplay,
+	tiff, wpa_supplicant, xcb-util,
 	xdriver_xf86-input-{acepad,aiptek,evdev,joystick,keyboard},
 	xdriver_xf86-input-{mouse,synaptics,void},
 	xdriver_xf86-video-{chips,dummy,geode,glide,intel,nv,wsfb},
@@ -27,6 +27,7 @@
 	Issues resolved (http://bugs.uclibc.org):
 
 	#3205: Failing chmod when running "make" in buildroot (openssl)...
+	#3277: quagga fails to build with SNMP support
 	#3283: See why nfs-utils needs fakeroot, and convert to autotools
 
 2011.02-rc1, Released February 14th, 2011:
diff --git a/package/quagga/quagga.mk b/package/quagga/quagga.mk
index d2b14440c8..a807f0f4a7 100644
--- a/package/quagga/quagga.mk
+++ b/package/quagga/quagga.mk
@@ -67,6 +67,10 @@ endif
 ifeq ($(BR2_PACKAGE_QUAGGA_SNMP),y)
 QUAGGA_CONF_OPT+=--enable-snmp
 QUAGGA_DEPENDENCIES+=netsnmp
+# SNMP support tries -lcrypto by default, disable it if we ain't got openssl
+ifneq ($(BR2_PACKAGE_OPENSSL),y)
+QUAGGA_CONF_OPT+=--without-crypto
+endif
 else
 QUAGGA_CONF_OPT+=--disable-snmp
 endif