hiawatha: bump to version 8.5
[Peter: license is explictly GPLv2, not GPLv2+] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
b98ccc4ea2
commit
fcc1b0cca0
@ -9,22 +9,22 @@ This patch adds a ENABLE_SSL_EXTERNAL option, which, when used in
|
|||||||
addition to ENABLE_SSL, tells Hiawatha's build system to link against
|
addition to ENABLE_SSL, tells Hiawatha's build system to link against
|
||||||
the already existing PolarSSL library instead of building its own.
|
the already existing PolarSSL library instead of building its own.
|
||||||
|
|
||||||
[Gustavo]: Update for version 8.3
|
[Gustavo]: Update for version 8.5
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||||
|
|
||||||
diff -Nura hiawatha-8.3.orig//CMakeLists.txt hiawatha-8.3/CMakeLists.txt
|
diff -Nura hiawatha-8.5.orig/CMakeLists.txt hiawatha-8.5/CMakeLists.txt
|
||||||
--- hiawatha-8.3.orig//CMakeLists.txt 2012-05-23 14:22:26.000000000 -0300
|
--- hiawatha-8.5.orig/CMakeLists.txt 2012-09-12 09:29:34.347994799 -0300
|
||||||
+++ hiawatha-8.3/CMakeLists.txt 2012-05-24 08:13:00.007107500 -0300
|
+++ hiawatha-8.5/CMakeLists.txt 2012-09-12 09:33:15.983118183 -0300
|
||||||
@@ -10,6 +10,7 @@
|
@@ -9,6 +9,7 @@
|
||||||
option(ENABLE_MONITOR "Enable support for the Hiawatha Monitor." off)
|
option(ENABLE_MONITOR "Enable support for the Hiawatha Monitor." off)
|
||||||
option(ENABLE_RPROXY "Enable reverse proxy support in Hiawatha." on)
|
option(ENABLE_RPROXY "Enable reverse proxy support in Hiawatha." on)
|
||||||
option(ENABLE_SSL "Enable SSL (PolarSSL) support in Hiawatha." on)
|
option(ENABLE_SSL "Enable SSL (PolarSSL) support in Hiawatha." on)
|
||||||
+option(ENABLE_SSL_EXTERNAL "Enable SSL (PolarSSL) as an external library." off)
|
+option(ENABLE_SSL_EXTERNAL "Enable SSL (PolarSSL) as an external library." off)
|
||||||
option(ENABLE_TOOLKIT "Enable the URL toolkit in Hiawatha" on)
|
option(ENABLE_TOMAHAWK "Enable Tomahawk in Hiawatha" off)
|
||||||
option(ENABLE_XSLT "Enable XSLT support in Hiawatha." on)
|
option(ENABLE_TOOLKIT "Enable the URL toolkit in Hiawatha" on)
|
||||||
|
option(ENABLE_XSLT "Enable XSLT support in Hiawatha." on)
|
||||||
@@ -85,19 +86,23 @@
|
@@ -88,19 +89,23 @@
|
||||||
|
|
||||||
# PolarSSL
|
# PolarSSL
|
||||||
if(ENABLE_SSL)
|
if(ENABLE_SSL)
|
||||||
@ -49,7 +49,7 @@ diff -Nura hiawatha-8.3.orig//CMakeLists.txt hiawatha-8.3/CMakeLists.txt
|
|||||||
# Configure files
|
# Configure files
|
||||||
configure_file(config.h.in config.h)
|
configure_file(config.h.in config.h)
|
||||||
foreach (configfile ${config_files_in})
|
foreach (configfile ${config_files_in})
|
||||||
@@ -118,7 +123,9 @@
|
@@ -121,7 +126,9 @@
|
||||||
target_link_libraries(hiawatha ${CRYPT_LIBRARY} pthread ${Z_LIBRARY})
|
target_link_libraries(hiawatha ${CRYPT_LIBRARY} pthread ${Z_LIBRARY})
|
||||||
if(ENABLE_SSL)
|
if(ENABLE_SSL)
|
||||||
target_link_libraries(hiawatha ${POLARSSL_LIBRARY})
|
target_link_libraries(hiawatha ${POLARSSL_LIBRARY})
|
||||||
|
@ -1,5 +1,7 @@
|
|||||||
HIAWATHA_VERSION = 8.4
|
HIAWATHA_VERSION = 8.5
|
||||||
HIAWATHA_SITE = http://www.hiawatha-webserver.org/files/
|
HIAWATHA_SITE = http://www.hiawatha-webserver.org/files/
|
||||||
|
HIAWATHA_LICENSE = GPLv2
|
||||||
|
HIAWATHA_LICENSE_FILES = LICENSE
|
||||||
|
|
||||||
ifeq ($(BR2_PACKAGE_HIAWATHA_SSL),y)
|
ifeq ($(BR2_PACKAGE_HIAWATHA_SSL),y)
|
||||||
HIAWATHA_CONF_OPT += -DENABLE_SSL_EXTERNAL=ON -DENABLE_SSL=ON
|
HIAWATHA_CONF_OPT += -DENABLE_SSL_EXTERNAL=ON -DENABLE_SSL=ON
|
||||||
|
Loading…
Reference in New Issue
Block a user