sofia-sip: new package

[Thomas:
 - Add better Config.in help text.
 - Fix the hash file format.
 - Fix comment header in .mk file.
 - Remove SOURCE variable, as it had the default value.
 - Add dependency on host-pkgconf, used by the configure script.
 - Add LICENSE and LICENSE_FILES variables.
 - Do not use BR2_HAVE_DOCUMENTATION, this option has been
   removed. Instead, always disable doxygen.
 - Simplify the IPv6 test.
 - Add optional dependency on OpenSSL.
 - Fixup the handling of the --enable-ndebug.]

Signed-off-by: Gregory Dymarek <gregd72002@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Gregory Dymarek 2014-12-12 15:42:46 +00:00 committed by Thomas Petazzoni
parent 1b12b7e818
commit fbfa665350
5 changed files with 77 additions and 0 deletions

View File

@ -865,6 +865,7 @@ menu "Networking"
source "package/rtmpdump/Config.in"
source "package/slirp/Config.in"
source "package/snmppp/Config.in"
source "package/sofia-sip/Config.in"
source "package/thrift/Config.in"
source "package/usbredir/Config.in"
source "package/wvstreams/Config.in"

View File

@ -0,0 +1,10 @@
config BR2_PACKAGE_SOFIA_SIP
bool "sofia-sip"
help
Sofia-SIP is an open-source SIP User-Agent library,
compliant with the IETF RFC3261 specification (see the
feature table). It can be used as a building block for SIP
client software for uses such as VoIP, IM, and many other
real-time and person-to-person communication services.
http://sofia-sip.sourceforge.net/

View File

@ -0,0 +1,26 @@
From bcd0f17fd83f2dfe570a3ab17249a5c7290b27f2 Mon Sep 17 00:00:00 2001
From: Pekka Pessi <Pekka.Pessi at nokia.com>
Date: Thu, 24 Mar 2011 14:45:21 +0200
Subject: [PATCH] soa_tag.h: reintroduce soatag_local_sdp_str_ref
Thanks to Erik Habicht <e.habicht at thiesen.com> for spotting it
---
libsofia-sip-ua/soa/sofia-sip/soa_tag.h | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/libsofia-sip-ua/soa/sofia-sip/soa_tag.h b/libsofia-sip-ua/soa/sofia-sip/soa_tag.h
index 723ca02..d9448d6 100644
--- a/libsofia-sip-ua/soa/sofia-sip/soa_tag.h
+++ b/libsofia-sip-ua/soa/sofia-sip/soa_tag.h
@@ -118,7 +118,7 @@ SOFIAPUBVAR tag_typedef_t soatag_local_sdp_ref;
SOFIAPUBVAR tag_typedef_t soatag_local_sdp_str;
#define SOATAG_LOCAL_SDP_STR_REF(x) \
soatag_local_sdp_str_ref, tag_str_vr(&(x))
-SOFIAPUBVAR tag_typedef_t soatag_session_sdp_str_ref;
+SOFIAPUBVAR tag_typedef_t soatag_local_sdp_str_ref;
#define SOATAG_AF(x) soatag_af, tag_int_v((x))
SOFIAPUBVAR tag_typedef_t soatag_af;
--
1.7.7

View File

@ -0,0 +1,2 @@
# Locally computed
sha256 2b01bc2e1826e00d1f7f57d29a2854b15fd5fe24695e47a14a735d195dd37c81 sofia-sip-1.12.11.tar.gz

View File

@ -0,0 +1,38 @@
################################################################################
#
# sofia-sip
#
################################################################################
SOFIA_SIP_VERSION = 1.12.11
SOFIA_SIP_SITE = http://downloads.sourceforge.net/project/sofia-sip/sofia-sip/$(SOFIA_SIP_VERSION)
SOFIA_SIP_INSTALL_STAGING = YES
SOFIA_SIP_DEPENDENCIES = host-pkgconf
SOFIA_SIP_LICENSE = LGPLv2.1+
SOFIA_SIP_LICENSE_FILES = COPYING COPYRIGHTS
SOFIA_SIP_CONF_OPTS = --with-doxygen=no
ifeq ($(BR2_TOOLCHAIN_BUILDROOT_INET_IPV6),)
SOFIA_SIP_CONF_OPTS = --disable-ip6
endif
ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
SOFIA_SIP_CONF_OPTS += --with-glib
SOFIA_SIP_DEPENDENCIES += libglib2
else
SOFIA_SIP_CONF_OPTS += --without-glib
endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
SOFIA_SIP_CONF_OPTS += --with-openssl
SOFIA_SIP_DEPENDENCIES += openssl
else
SOFIA_SIP_CONF_OPTS += --without-openssl
endif
ifeq ($(BR2_ENABLE_DEBUG),y)
SOFIA_SIP_CONF_OPTS += --enable-ndebug
endif
$(eval $(autotools-package))