package/waffle: bump to version 1.7.0

This bump will fix the following build failure raised since bump of
wayland to version 1.20.0 in commit
f94ba5c31c thanks to
71d46212a9
and
2c33597245:

/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/powerpc64-buildroot-linux-gnu/9.3.0/../../../../powerpc64-buildroot-linux-gnu/bin/ld: ../../lib/libwaffle-1.so.0.6.1: undefined reference to `wl_proxy_get_version'
/home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/powerpc64-buildroot-linux-gnu/9.3.0/../../../../powerpc64-buildroot-linux-gnu/bin/ld: ../../lib/libwaffle-1.so.0.6.1: undefined reference to `wl_proxy_marshal_flags'

https://gitlab.freedesktop.org/mesa/waffle/-/tags/v1.7.0
https://gitlab.freedesktop.org/mesa/waffle/-/tags/v1.6.3
https://gitlab.freedesktop.org/mesa/waffle/-/tags/v1.6.2

Fixes:
 - http://autobuild.buildroot.org/results/1fb1540b0ae6037140f386f44d6e17735f0674c4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2022-08-07 15:53:57 +02:00 committed by Thomas Petazzoni
parent efa5ff1489
commit fbf7d55421
4 changed files with 67 additions and 4 deletions

View File

@ -12,6 +12,8 @@ since CFLAGS defined by pc files are not used.
EGL_NO_X11 is defined in CFLAGS from egl.pc.
Signed-off-by: Romain Naour <romain.naour@gmail.com>
[Upstream status:
https://gitlab.freedesktop.org/mesa/waffle/-/merge_requests/111]
---
src/waffle/CMakeLists.txt | 8 ++++++++
1 file changed, 8 insertions(+)

View File

@ -0,0 +1,59 @@
From 2c33597245bb74f19104f0a858cd40e80b26991d Mon Sep 17 00:00:00 2001
From: Philipp Zabel <p.zabel@pengutronix.de>
Date: Fri, 17 Dec 2021 13:46:40 +0100
Subject: [PATCH] wayland: fix build against version 1.20
Wayland 1.20 introduces two new symbols wl_proxy_marshal_flags and
wl_proxy_marshal_array_flags, which need to be wrapped as well.
Closes: https://gitlab.freedesktop.org/mesa/waffle/-/issues/76
Signed-off-by: Philipp Zabel <p.zabel@pengutronix.de>
[Retrieved from:
https://gitlab.freedesktop.org/mesa/waffle/-/commit/2c33597245bb74f19104f0a858cd40e80b26991d]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
src/waffle/wayland/wayland_sym.h | 18 ++++++++++++++++++
src/waffle/wayland/wayland_wrapper.h | 2 ++
2 files changed, 20 insertions(+)
diff --git a/src/waffle/wayland/wayland_sym.h b/src/waffle/wayland/wayland_sym.h
index 3d48625..4c6ac8d 100644
--- a/src/waffle/wayland/wayland_sym.h
+++ b/src/waffle/wayland/wayland_sym.h
@@ -26,3 +26,21 @@ WAFFLE_WAYLAND_SYM(struct wl_proxy *, wl_proxy_marshal_constructor,
WAFFLE_WAYLAND_SYM(struct wl_proxy *, wl_proxy_marshal_constructor_versioned,
(struct wl_proxy *proxy, uint32_t opcode,
const struct wl_interface *interface, uint32_t version, ...))
+
+WAFFLE_WAYLAND_SYM(struct wl_proxy *,
+ wl_proxy_marshal_flags,
+ (struct wl_proxy * p,
+ uint32_t opcode,
+ const struct wl_interface *interface,
+ uint32_t version,
+ uint32_t flags,
+ ...))
+
+WAFFLE_WAYLAND_SYM(struct wl_proxy *,
+ wl_proxy_marshal_array_flags,
+ (struct wl_proxy * p,
+ uint32_t opcode,
+ const struct wl_interface *interface,
+ uint32_t version,
+ uint32_t flags,
+ union wl_argument *args))
diff --git a/src/waffle/wayland/wayland_wrapper.h b/src/waffle/wayland/wayland_wrapper.h
index 4af2f64..6addf4f 100644
--- a/src/waffle/wayland/wayland_wrapper.h
+++ b/src/waffle/wayland/wayland_wrapper.h
@@ -65,5 +65,7 @@ struct wl_display;
#define wl_proxy_marshal (*wfl_wl_proxy_marshal)
#define wl_proxy_marshal_constructor (*wfl_wl_proxy_marshal_constructor)
#define wl_proxy_marshal_constructor_versioned (*wfl_wl_proxy_marshal_constructor_versioned)
+#define wl_proxy_marshal_flags (*wfl_wl_proxy_marshal_flags)
+#define wl_proxy_marshal_array_flags (*wfl_wl_proxy_marshal_array_flags)
#include <wayland-client-protocol.h>
--
GitLab

View File

@ -1,3 +1,5 @@
# From https://gitlab.freedesktop.org/mesa/waffle/uploads/42030b1cc0f81fd738152104e1811919/waffle-1.7.0.sha256sums
sha256 69e42d15d08f63e7a54a8b8770295a6eb04dfd1c6f86c328b6039dbe7de28ef3 waffle-1.7.0.tar.xz
# Locally calculated
sha256 234e65bdd2dd8f7d3bc8e9ad1a7cc80fce78a1deed3a04fe7f1d2c2edac0cd8a waffle-v1.6.1.tar.bz2
sha256 630844d1911c8a1b7b888a1de9097c4860b7e381362fd5aa64141d58ab7ecc9b LICENSE.txt

View File

@ -4,9 +4,9 @@
#
################################################################################
WAFFLE_VERSION = 1.6.1
WAFFLE_SOURCE = waffle-v$(WAFFLE_VERSION).tar.bz2
WAFFLE_SITE = https://gitlab.freedesktop.org/mesa/waffle/-/archive/v$(WAFFLE_VERSION)
WAFFLE_VERSION = 1.7.0
WAFFLE_SOURCE = waffle-$(WAFFLE_VERSION).tar.xz
WAFFLE_SITE = https://gitlab.freedesktop.org/mesa/waffle/uploads/9eaadda4ec2ed1d8a26ddefd2cfd16be
WAFFLE_INSTALL_STAGING = YES
WAFFLE_LICENSE = BSD-2-Clause
WAFFLE_LICENSE_FILES = LICENSE.txt